[mythtv-users] qt 3.3.8 in mac 0SX 10.5 - won't compile

Nick F nikos.f at gmail.com
Sun Nov 18 00:26:00 UTC 2007


I've just updated my mac mini (intel Core Duo model) to Leopard 10.5.
I run SVN on my backend , so I need to compile a recent SVN on my mac
frontend.  I'm hitting a problem when I try to install QT3.3.8

It fails with
src/qt-mac-free-3.3.8/include/qglobal.h:187:6: error: #error "This
version of Mac OS X is unsupported"

I've tried compiling manually, as well as using osx-packager.pl.
(which I note still points to QT3.3.6 - although I tried pointing that
to 3.3.8 as well).

I had no problems before (with 10.4).  Surfing the support forums for
Trolltech all (unhelpfully) suggest porting to QT4, and saying that
QT3 is EOL.

I'm sure I've heard of people using Mythfrontend with 10.5 - so I'm
sure I'm overlooking something simple with QT.  Is there a patch /
workaround that my googling hasn't found?

Many thanks,

(luckily I can still boot to my Linux partition on my mac and use Myth
on this computer - but I'd love to get this working).

More information about the mythtv-users mailing list