[mythtv-users] gutsy install frontend gui does appear if not logged in as mythtv

John Brown info at johnbrown.com.au
Fri Nov 16 10:01:59 UTC 2007

David Whyte wrote:
> On Nov 12, 2007 10:07 PM, John Brown <info at johnbrown.com.au> wrote:
>> My 3rd (and final?) problem I am having -- after just doing a fresh
>> install of ubuntu gutsy on an AMD64 and installed mythtv frontend and
>> backend -- is that if I log on as anything but mythtv the frontend gui
>> does not appear after I run it. The system monitor shows it as
>> 'sleeping' but the gui never appears, and I don't get any error messages.
>> The same thing happens on a remote Feisty frontend
>> Given the lack of error messages, I don't know where to start with this one.
> Are you running the 'mythfrontend' application from a terminal to see
> what the output is?

I wasn't, but now that have I can see that the problem is that when I 
run mythfrontend in any user other than mythtv it 'hangs' at the point 
it tries to access the database: (see the following output)

jbcp at ubuntu64:~$ /usr/bin/mythtv
2007-11-13 21:09:43.532 Using runtime prefix = /usr
2007-11-13 21:09:43.565 Gnome-Screensaver support enabled
2007-11-13 21:09:43.611 DPMS is active.
2007-11-13 21:09:43.797 New DB connection, total: 1

... then nothing...

However, when I am logged in a user mythtv I get the following output:

2007-11-13 21:13:09.617 Using runtime prefix = /usr
2007-11-13 21:13:09.662 Gnome-Screensaver support enabled
2007-11-13 21:13:09.662 DPMS is active.
2007-11-13 21:13:09.748 New DB connection, total: 1
2007-11-13 21:13:09.765 Connected to database 'mythconverg' at host:

... then it continues on and the frontend GUI appears and everything 
works fine (the subject lines has this the other way around, which is 
wrong, sorry)



Dr John Brown, PhD(Clin.Psych) MAPS
Mobile: 0429 455 504
Email: info at johnbrown.com.au
Web: www.johnbrown.com.au

More information about the mythtv-users mailing list