[mythtv-users] /usr/bin/ld: cannot find -lXvMCNVIDIA

brad dreisbach bradd at ameri.ca
Mon Nov 12 19:33:38 UTC 2007


I have been using myth svn for the past year or so without any  
issues.  I recently upgraded to
the latest nvidia driver from the 9755 version.  Since then I am  
unable to compile mythtv
using the XvMCNVIDIA library.  I get the following:

ccache g++ -shared -Wl,-soname,libmyth-0.20.so.0 -o libmyth-0.20.so. 
0.20.0 dialogbox.o lcddevice.o mythcontext.o mythwidgets.o  
oldsettings.o remotefile.o settings.o util.o mythwizard.o uitypes.o  
xmlparse.o mythplugin.o mythdialogs.o audiooutput.o httpcomms.o  
mythmedia.o mythmediamonitor.o uilistbtntype.o generictree.o  
managedlist.o DisplayRes.o volumecontrol.o volumebase.o  
audiooutputbase.o dbsettings.o screensaver.o screensaver-null.o  
output.o langsettings.o mythdbcon.o audiooutputnull.o  
DisplayResScreen.o util-x11.o qmdcodec.o virtualkeyboard.o  
mythobservable.o mythsocket.o themeinfo.o audiooutputoss.o mythhdd.o  
mythcdrom.o mediamonitor-unix.o mythcdrom-linux.o audiooutputalsa.o  
jsmenu.o jsmenuevent.o audiooutputarts.o screensaver-x11.o  
DisplayResX.o moc_dialogbox.o moc_lcddevice.o moc_mythcontext.o  
moc_mythwidgets.o moc_settings.o moc_mythwizard.o moc_uitypes.o  
moc_mythdialogs.o moc_httpcomms.o moc_mythmedia.o  
moc_mythmediamonitor.o moc_uilistbtntype.o moc_managedlist.o  
moc_virtualkeyboard.o moc_mythcdrom.o moc_jsmenu.o moc_screensaver- 
x11.o  -L/usr/lib64/qt-3.3/lib -L../libmythsamplerate - 
lmythsamplerate-0.20 -L../libmythsoundtouch -lmythsoundtouch-0.20 - 
lfreetype -lmp3lame -lasound -lartsc -lgmodule-2.0 -ldl -lgthread-2.0 - 
lrt -lglib-2.0 -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCNVIDIA -lXvMC - 
lGL -lGLU -lqt-mt -lXext -lX11 -lm -lpthread
/usr/bin/ld: cannot find -lXvMCNVIDIA
collect2: ld returned 1 exit status
make[2]: *** [libmyth-0.20.so.0.20.0] Error 1

the nvidia library path is in ld.so.conf and my /etc/X11/XvMCConfig  
file also contains the full path to the library.
I tried adding a -L/usr/lib64/nvidia-graphics-100.14.19 switch to the  
above g++ command and I even tried adding
the nvidia library path to my LD_LIBRARY_PATH, but I continue to get  
this error.  Any ideas?


More information about the mythtv-users mailing list