[mythtv-users] dd_v_ tables missing from mythconverg

R. G. Newbury newbury at mandamus.org
Mon Nov 12 14:14:50 UTC 2007

William Munson wrote:
> R. G. Newbury wrote:
>> I think I have borked by mythconverg database and do not have an old 
>> enough backup to reconstruct the prior state.
>> SVN 14830 segfaulted at every attempt to play LiveTV or from the 
>> library. I stepped back to 14794. But I think the error may have 
>> predated that as I have listings for only 8 days. This is most likely 
>> the result of a schema advance and revert...Operator error!
>> DBSchemaVer is 1201. Mythfilldatabase reports that is cannot do inserts 
>> to various "dd_v_xxx" tables. Those tables do not exist.
>> So, how do I "re-update" and make it stick? As noted, 14830 segfaults badly.
>> Geoff
>> _______________________________________________
> I have not tried this myself but you should be able to change 
> DBSchemaVer in the settings table to a lower number and rerun 
> mythtv-setup to re-upgrade your database. With a reasonably current SVN 
> I have a version of 1201.

I tried something like this...I changed DBSchemaVer to 1200 in 
mysql...but I cannot now be sure that I didn't just restart mythbackend 
and frontend....I cannot remember.
But whatever I did, changed DBSchemaVer to 1201 again, but DID NOT 
create the missing tables....

I will try it again, running mythtv-setup first.

Anyone else have any good ideas? (I don't mind hearing *bad* ideas, but 
I make no promises about using them!)


       Tux says: "Be regular. Eat cron flakes."

More information about the mythtv-users mailing list