[mythtv-users] "Internal" player problems

Josh White jaw1959 at gmail.com
Mon Nov 12 13:28:15 UTC 2007

I hate to post a vague description of a problem, but I've had zero success
working with the internal player in mythvideo or mythdvd.  I'll do my best
to describe my problem below, but I do not have any command line output or
any logs to post.  I'm not really sure how to generate such information in
this case, so bear with me.  I am away from my machine for the next 10 hours
or so, so if such information is required to solve this problem, it will
take me some time to gather it.

I love the idea of using a player that is integrated with the rest of the
system, but it seems I can't on any of my systems.  I'm running on three
different machines, with two of them running Ubuntu and the latests version
of mythtv from the repositories (this would include my backend/frontend, and
a stand alone frontend), and I'm running a copy of mythbuntu on my main
frontend/secondary backend .  None of these machines seem to be able to use
the internal player for anything I try to use.

When I try to watch a DVD, it seems to quickly load every title it should
load, like it will flash each preview for about a second, then the FBI
warning for a second, and then finally flash he main menu screen for a
second just before it closes.  If I switch the player to mplayer, it simply
works, though it only plays the main title, and then only if it's title#1.

In mythvideo, when I use the internal player, all I get is a black screen,
and the only thing I can do to solve that is switch users and kill
mythfronend.  Again, switching the player to mplayer allows me to play the
movie, but it's not what I want.

I've been searching the wiki for help, but the only mention I can find is to
either setup some external player (mplayer, xine, etc) or to "simply" use
the internal player.  I'd love to "simply" use the internal player, but I
can't seem to make it work.  Has anyone else experienced similar problems?
Am I doomed to using a different player for my files?

As I said, I'm running on three different machines.  The only common links
between them all is they are all Ubuntu gutsy based, they all run Intel
processors (2 P4's and a Pentium D) and they all have nVidia cards.  My
various video cards include a Geforce 7900gt, a Geforce2 whatever, and a
Geforce FX5200.   The two newer cards are running the latest Ubuntu
supported proprietary drivers, and the Geforce2 is running the latest
version of the "legacy" driver from the standard Ubuntu repositories.

I'd be happy to furnish anyone with any more details if I can.  Any hints
would be appreciated.  I have been unable to find a way to change any
settings or any configuration of any kind for the "Internal" player, and I'm
unaware if such a thing even exists (short of tweaking the source
code...something I am wholly unqualified to do).

Any and all tips/hints/pointers/etc. would be appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071112/2a11ab38/attachment.htm 

More information about the mythtv-users mailing list