[mythtv-users] [Fwd: HDHomerun can't tune just one multiplex]

David Shay david at shay.net
Fri Nov 9 17:54:32 UTC 2007

On 11/9/07, Greg Woods <greg at gregandeva.net> wrote:
> I hope "multiplex" is the correct term here.
> What happened is that, for no apparent reason, I suddenly could no
> longer record off my HDHomerun. LiveTV worked fine, but attempting to
> record would fail and produce an empty recording. I already tried
> posting about this complete with log entries and got no response, so I
> decided to just start over. I upgraded to the latest SVN (14794). I
> deleted
> the HDHR capture cards and the
> Comcast Digital video source. I created a brand new Digital Cable video
> source, then deleted all the channels from the channel table that had
> the video source ID of the old Comcast Digital video source. Then I did
> the channel scan at QAM-256, repeated at QAM-64, and went through the
> tedious process of tuning every channel found in the scan and using the
> OSD editor (brought up with the "e" key) to enter callsign, channel
> name, and XMLTVID (obtained from the SchedulesDirect lineup web page).
> After this and a "mythfilldatabase --do-channel-updates" run, my
> recordings
> worked again: almost.
> The problem is that there are 8 channels from 81#0 to 81#7 that were
> found in the channel scan, but I cannot tune them. I am certain that
> some of them are valid channels; my local ABC affiliate that I used to
> be able to get should be there. I have quick tune set, and I checked the
> "unencrypted channels only" box before doing the scan.
> I'm excited to find out what channels they are, because I have
> discovered to my astonishment that ESPN-2 in HD is available to my HDHR
> in the clear. Maybe the main ESPN channel is one of the missing ones,
> and I would definitely like to be able to get ABC programs in HD.
> What happens when I try to tune one of these channels in LiveTV is that I
> only
> get a partial lock; I get the
> now-infamous "you should have gotten a channel lock by now" popup
> window, and it stays in the "Partial Lock (L  )" state forever.
> Occasionally it will crap out and give me the "Error displaying video,
> press OK to return to menu" blue screen of death, but usually it just
> hangs with a partial lock until I hit escape or change the channel.
> Here's what "hdhomerun_config scan" shows:
> SCANNING: 567000000 (us-cable:81, us-irc:81)
> LOCK: qam64 (ss=78 snq=17 seq=100)
> PROGRAM: 1: 0.0
> PROGRAM: 2: 0.0
> PROGRAM: 3: 0.0
> PROGRAM: 4: 0.0
> PROGRAM: 5: 0.0
> PROGRAM: 6: 0.0
> PROGRAM: 7: 0.0
> PROGRAM: 8: 0.0
> I don't see anything particularly unusual in this; all of the other
> channels also have PROGRAM reported as 0.0, and those channels are
> tunable and work through the guide once I manually enter the proper
> XMLTVID. There are also some with an even lower signal strength than
> this that tune fine.
> Anybody have any ideas how I might get these channels working?
> Thank you,
> --Greg

Before attempting to get them working in Myth, I would validate that they
work outside of Myth using the standard hdhomerun commands.  Per the above I
would do :

hdhomerun_config ffffffff set /tuner0/channel qam64:81
hdhomerun_config ffffffff set /tuner0/program 1
hdhomerun_config ffffffff save 0 test.mpg
mplayer (or whatever you prefer) test.mpg

Change the program in the second line to go through all 8 programs.  That
will validate what is really there and what the hdhomerun can really see

If that is all working, it would be good to get more debugging information
from the backend with -v all to see what is going on.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071109/857a8227/attachment-0001.htm 

More information about the mythtv-users mailing list