[mythtv-users] MythTV backend crashing constantly (SOLVED)

Steve Skarda steveskarda at gmail.com
Mon Nov 5 13:55:59 UTC 2007

On 11/3/07, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> On 11/03/2007 02:29 AM, Joe Auty wrote:
> > I think I have solved this problem... At least, so far, so good.
> >
> > It looks like the culprit was a piece of software called "MythGrowl"
> > for OS X was causing the backend to crash. The only other change I
> > made was to disable invoking mythfilldatabase automatically, I will
> > experiment with turning this back on and seeing what happens. However,
> > I have reason to believe that this wasn't the problem.
> >
> > For the benefit of others that might be experiencing crashes for this
> > or any other reason, I'll keep you guys posted :)
> What does MythGrowl do?  (I.e. any idea what the root cause is?  Is it
> just sending a lot of backend status queries (HTML/XML) or some other
> "known" way of crashing the backend?  If so, perhaps something like
> myth_recent_recordings.pl (in SVN trunk) or a similar Growl-specific
> script written to use the Perl bindings like myth_recent_recordings.pl
> could be used instead.)
> Mike
> _______________________________________________

I have had a similar problem with backend crashing but I do not have
Mythgrowl installed.   Nothing  shows up in the logs and I haven't had
responses to the posting of some debug outputs.   I upgraded from Fiesty to
latest Mythbuntu (based on Gutsy) last week.  That didn't help. I upgraded
to the stable + fixes weekly build of Mythbuntu but that didn't help.
Yesterday, I upgraded to the development truck weekly build of Mythbuntu and
my problem has not resurfaced yet.  It has been 24 hours with no crash which
is promising but I won't feel like it is really fixed until I see it run for
several days without a crash.

I think my problem may have something to do with having an EIT flag set
somewhere in the database (eitcache is empty and all channels have flag
turned off in mythconverg) because it started when I upgrade to schedules
direct and turned EIT on.   There was a fix for bad EIT data in truck
version that may not have gotten put back into stable + fixes.  See
developers list for more details.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071105/5f98f4c2/attachment.htm 

More information about the mythtv-users mailing list