[mythtv-users] HDHomeRun, 2nd NIC and dhcpd bootup issue

Mitch Gore mitchell.gore at gmail.com
Sun Nov 4 15:07:01 UTC 2007

On Nov 4, 2007 4:24 AM, William Munson <william_munson at bellsouth.net> wrote:

> R wrote:
> > I'm a long time user of MythTV and very much appreciate all the hard
> work everyone puts into the software. I recently decided I wanted a second
> HD tuner for OTA broadcasts and since I am already using 4 of 5 PCI slots, I
> decided to try a HDHomeRun.
> >
> > While setting it up, I determined that the HDHomeRun used DHCP to get an
> IP address so I first connected it to my home network so my router would
> provide the IP address. My MythTV server is connected to my home network via
> a PCI Gigabit Ethernet card (eth0). Once everything was up and running, I
> wanted to move the HDHomeRun off my home network. I enabled the
> motherboard's 10/100 Ethernet NIC (eth1) and configured dhcpd to provide an
> address to it. After directly connecting the HDHomeRun to eth1 and
> restarting mythbackend, the tuners were available and working without any
> other changes.
> >
> > Everything was great until my system was rebooted.
> >
> > Turns out that after the reboot mythbackend reported "device not found"
> for both HDHomeRun tuners. After manually restarting mythbackend, the tuners
> were back and working. Thinking that the problem might be related to the
> second NIC and DHCP, I reconnected the HDHomeRun to my home network,
> rebooted and found that indeed, the tuners were discovered after the server
> restart.
> >
> > When facing an issue such as this, I figure I'm not the first to
> experience it and search the internet for a solution. This time, I couldn't
> find a solution.
> >
> > Thinking that it might be a timing issue where the HDHomeRun did not yet
> have an address from my MythTV dhcpd server for the second NIC, I hunted in
> the code until I found the FindDevice function in
> libs/libmythtv/hdhrchannel.cpp. I noticed that it tries to "Discover" the
> HDHomeRun 6 times before reporting "device not found". I modified it to try
> 60 times to give the HDHomeRun a bit more time to get an IP address. After
> building and installing the change, I rebooted and found that the HDHomeRun
> was found by mythbackend after the server restart and my problem was solved.
> >
> > I don't know if the problem is unique to my configuration but, if not,
> perhaps my experience will help someone else.
> >
> > Richard
> >
> >


I have a similar setup.  I have two NICs in my BE and want to hook the HDHR
directly to the BE.  i have dhcpd installed but i am not sure what to use in
the configuration file.  My setup gives eth0 a connection to the network and
then the internet.  eth1 i want to hook directly to the HDHR.

Initially i wanted to bridge the two cards so the HDHR would still get an
address from my router.  I couldnt figure that out so i moved to another
dhcp server.  After reading i thought i found something saying this couldn't
be done.

How did you do it?  (could you post the .conf file) I think we need a wiki
on this.  If you could explain it to me then ill figure it out and publish
the how to.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071104/280b309a/attachment.htm 

More information about the mythtv-users mailing list