[mythtv-users] surround 5.1 sound

Ismo Tanskanen ismot at telemail.fi
Sat Nov 3 19:51:18 UTC 2007

007/11/3, Ismo Tanskanen <ismot>:
 > Is mythfrontend capable to send 5.1 sound out from soundcard's analog
 > connectors? I'm planning to buy cheap 5.1 speaker set to bedroom. They
 > don't use digital out, but connect directly to soundcard, which has 5.1
 > speaker outputs. SC is soundmax integrated (asus m2npv-mx)
 > Now, I only get sound from front speakers, even if there is 5.1 track. I
 > use internal player to play dvd. TV channels also transmit surround
 > sound often.

I have MVNPV-VM which is mostly similar to your board and I have same 
All my recordings are stereo only and it does not matter if I hear
sound only on the front speakers. I tried to make all speakers work
also with with MythTv to spread 2.0 sound over all 5 speakers but I
had no success.

MPlayer is playing videos nice 5.1 surround and that is more important 
to me.

You could probably solve this with a correct .asoundrc file, because I
think this is more ALSA's problem than MythTv's. I tried it this way
(see below), but without success. It would be great to hear that
someone knows how to set this up. You can find more information on
ALSA wiki.

This configuration worked with "aplay -D pcm.20to51 filename" but not
with MythTv. I tried changing sound output device in MythTv to
ALSA:20to51, ALSA:pcm.20to51, ALSA:device=20to51 etc but it didn't

# Expand stereo to all channels including LFE
pcm.20to51 {
type route
slave.pcm surround51
slave.channels 6
ttable.0.0 1
ttable.1.1 1
ttable.0.2 1
ttable.1.3 1
ttable.0.4 0.5
ttable.1.4 0.5
ttable.0.5 0.5
ttable.1.5 0.5

# Create the Master mixer device that controls *all* channels
# I call it Master because alsamixer has no Master, only PCM
pcm.!default {
type softvol
slave.pcm "20to51"
control {
name "Master"
card 0


Thanks for response. Does mplayer play videos in 5.1 format 
automatically, or does it need any command line parameters to do that?

More information about the mythtv-users mailing list