[mythtv-users] MythWeb still won't sort and filter with auth enabled - bump; paging Xris

Jay R. Ashworth jra at baylink.com
Sat Nov 3 06:32:12 UTC 2007

On Thu, Nov 01, 2007 at 10:05:29AM -0700, Chris Petersen wrote:
> Joe Ripley wrote:
> > You should still see cookies in your browser for authenticated mode
> > (at least I do it Firefox).
> This is the key point.  You should still see a cookie -- if not, there
> is a good chance that something else is going wrong that might be the
> root cause of both problems.

I see 3 cookies, while a session is active; one with no name for
/mythweb/tv; session.  One is cookie_test; session.

And one is mythweb_id, which appears to have an expiration date a
couple minutes *before* just now.  Its content is a big scarey base 36
hash.  Roughly, its expire time is the login time of the session.

It's actually still there in Firefox's list, even though it *says* it
should be expired...

> > Check your file system to see if you have
> > any PHP session files kicking around.  They're usually called
> > 'sess_*'.  On my SuSE 10.2 installation, these session files live in
> > '/var/lib/php5'.
> You shouldn't have any for MythWeb.  I use database-based sessions, and
> it's all controlled with MythWeb itself and overrides any php.ini setting.
> Then again, I'm assuming you're running MythTV 0.19 or later, too.

0.20.2, from Packman SuSE RPMs; SuSE 10.2 with all the standard package
revs; everything's from RPM.

-- jra
Jay R. Ashworth                   Baylink                      jra at baylink.com
Designer                     The Things I Think                       RFC 2100
Ashworth & Associates     http://baylink.pitas.com                     '87 e24
St Petersburg FL USA      http://photo.imageinc.us             +1 727 647 1274

More information about the mythtv-users mailing list