[mythtv-users] Removing commercials

Harry Devine lifter89 at comcast.net
Sat Nov 3 03:11:23 UTC 2007

Michael Rice wrote:
> On 11/1/07, Harry Devine <lifter89 at comcast.net> wrote:
>> Yeah, I found some settings in Mythtv-Setup to allow commercial flagging
>> (which I had selected) and checkboxes to allow each of the 4 user jobs
>> (which I didn't have selected).  I turned on the User Job #1 box and
>> went into my recording, clicked the right arrow and told it to run the
>> job.  It seemed to run for about 2 hours, and when I watched it, the
>> commercials were still in there.  I had to FF thru them all.  During
>> that 2 hour period, Mythweb said that the job was finished, but it never
>> actually removed anything.
> The script on the wiki uses the -i option to mythtranscode like this:
> mythtranscode --honorcutlist --showprogress -i $VIDEODIR/$FILENAME -o
> That doesn't work.  Try using this instead:
> mythtranscode --honorcutlist -c $CHANID -s $STARTTIME --showprogress
> Apparently --honorcutlist doesn't work with -i.
> You will need to pass chanid and starttime into the script.
> And call it:
> /usr/local/bin/RemoveCommercials %DIR% %FILE% %CHANID% %STARTTIME%
> Hope that helps.  Works for me now.
OK, I made that change to the script, and setup another recording last 
night.  I setup the recording job via Mythweb and told it to flag 
commercials, and to run the Remove Commercials user job (formerly User 
Job #1).  I just checked the recording and the commercials are still in 
there, so obviously, that didn't work either.  Would there be any 
information in the logs somewhere that I could look at?


More information about the mythtv-users mailing list