[mythtv-users] Slightly OT - ATrpms and yum

Calvin Dodge caldodge at gmail.com
Thu Nov 1 17:59:57 UTC 2007

On Nov 1, 2007 11:35 AM, vamythguy <vamythguy at gmail.com> wrote:
> I've seen others reporting the same issue, but their resolutions don't seem
> to work for me.  "yum --skip-broken upgrade" is still not working:

I had the same problem (yum bombs out with same error in spite of
"--skip-broken"). I had another system with the latest kernel (since
it doesn't have ivtv installed, it had no problem with the download),
so I manually installed that kernel.

After rebooting to the new kernel, the /dev/video* nodes were still
being created by udev, which means the new kernels come with working
ivtv modules.  I then tried Mythtv, and it worked fine (Live TV) with
my PVR-500 (subsequent recording also worked). Right now I'm running
on kernel-PAE- (I went a little buy-crazy when
Crucial had 1 gig DDR2s for $40 each, so my backend has 4 gigs of
RAM), and all of last night's shows (including the delightful "Pushing
Daisies") recorded without a hitch.

Anyway, I did "rpm --nodeps -e" to remove the older kernels and the
ivtv-kmdl packages.

My final step was to remove the "ivtv" package today, then restart
mythbackend. It's still working fine, so it seems obvious it doesn't
depend on the "ivtv" package for its functionality.

So my recommendatiion is to remove the ivtv and ivtv-kmdl packages
("rpm -e --repackage yourpackagenameshere"), then run "yum -y update".

(Repackage creates rpms from the existing files - handy if you realize
too late you've deleted a package which you don't have the rpm file

It worked for me, so I suspect it will work for you.


More information about the mythtv-users mailing list