[mythtv-users] SA3250HD channels over firewire (was SA3250HD questions cleared up)

Mike LaPlante mike at dividia.net
Thu May 31 15:23:06 UTC 2007

Sorry to reply to myself, but here's an update. I've been through a few 
cable boxes from Charter, had some issues with them that were unrelated 
to Myth. The Charter office in my area is supposed to swap bad STB's for 
good ones, however, in reality they seem to take whatever the customer 
brings in, throw it in a pile and grab a different one. I'm pretty sure 
the one I took in that was acting up for me will end up in several more 
people's living rooms. Bad business practice if you ask me.......

ANYWAY, my latest STB is working like a champ, it's still an SA3250HD, 
but I have it setup as a 4200 per Allan's suggestion, and it works. It 
changes channels reliably. The only time I have trouble is when I try to 
change to an encrypted HD channel, or to a channel below 100 (analog 
channels). I knew the encrypted HD stuff would be a problem, however, I 
had expected the lower channels to record through the firewire as well. 
Not really a problem I have two Hauppauge cards for those channels, but 
3 tuners > 2 tuners  :-)  After changing to one of these trouble 
channels have to do a series of 1394 cable unplugs and such until it 

So if it helps in the development process any here is some info.
Version :
rpm -q mythtv     mythtv-0.21-159_trunk_r13460.fc6

Plugreport :
Host Adapter 0
Node 0 GUID 0x001ac39157760000
oMPR n_plugs=1, data_rate=2, bcast_channel=63
oPCR[0] online=1, bcast_connection=0, n_p2p_connections=1
    channel=0, data_rate=2, overhead_id=0, payload=146
iMPR n_plugs=0, data_rate=2

SA3250HD setup in Myth as a 3250HD does NOT change channels correctly, 
but set as 4200 it does. I'm willing to do any testing that may help.

Thanks for the replies

More information about the mythtv-users mailing list