[mythtv-users] Why is DVD burning failing with ffmpeg?

Michael Williams gberz3 at gmail.com
Sat May 12 04:24:49 UTC 2007

I'm running version SVN-r8993.  As for the command, it is huge:

ffmpeg -y -f s16le -ar 48000 -ac 2 -i /tmp/work/1/audout -f rawvideo - 
pix_fmt yuv420p -s 480x480 -aspect 1.33333 -r 0.0333667 -i /tmp/work/ 
1/vidout -aspect 1.33333 -r 0.0333667 -s 720x480 -b 4771k -vcodec  
mpeg2video -qmin 5 -ab 192 -ar 48000 -acodec ac3 -f dvd "/tmp/work/1/ 

. . .so far as I can see, the latest version(s) of ffmpeg don't have  
an "-ar" option, so I removed that and tried again.  It still  
failed.  In fact, I tried removing, one-by-one different combinations  
of options, and nothing ever changed;  which leads me to believe that  
perhaps something is happening earlier in the chain and the output  
isn't sufficient to inform me as to what is actually occurring.  For  
instance, perhaps mencoder hiccups and produces 0k sized files or  
something, and ffmpeg simply hiccups and returns a nonsensical  
error.  In fact the only information I get is that ffmpeg had an exit  
code of "256".  I'm not even sure what that means.

On May 11, 2007, at 11:50 PM, <jdonohue654-mythtv at yahoo.com>  
<jdonohue654-mythtv at yahoo.com> wrote:

>> This is extreeeeeemely frustrating. Is anyone out
> there actually
>> getting FFMpeg re-encoding via MythArchive to work?
> If so, what
>> version of each plugin are you using, and what
> version of FFMpeg are
> you using?
> It works for me. I'm using the latest from the
> 0.20.fixes branch.
> I'm using debian-testing, but the latest ffmpeg in
> debian is broken as far as I can tell for some lib
> compatiblity reason (sorry, I don't know the details).
> So mytharchive will fail for me if I use the latest
> ffmpeg, so I have pinned the version to
> 0.cvs20060823-8.
> It might help if you can dig through the mytharchive
> logs and post the command that is failing.

More information about the mythtv-users mailing list