[mythtv-users] Runnig Mythfilldatabase deletes DataDirect lineup???.

Lan Barnes lan at falleagle.net
Fri May 11 18:01:37 UTC 2007

On Thu, May 10, 2007 10:25 pm, R. G. Newbury wrote:
> William Munson wrote:
>> R. G. Newbury wrote:
>>> Michael T. Dean wrote:
>>>> On 05/08/2007 11:15 PM, R. G. Newbury wrote:
>>>>> A weird problem has arisen. I have 2 lineups at labs.zap2it.com, one
>>>>> for
>>>>> analog cable and one digital.
>>>>> Whenever mythfilldatabase runs automatically, the analog cable lineup
>>>>> gets cleared (except for 3 channels which are also in the digital
>>>>> lineup
>>>>>   at different channels, but which zap2it describes with the same
>>>>> xmltvid).
>>>> You've got a broken video sources configuration.  My recommendation is
>>>> to use Delete all video sources.
>>>> http://www.gossamer-threads.com/lists/mythtv/users/264034#264034
>>>> mythfilldatabase automatically removes from your DataDirect lineup any
>>>> channels that are not being used so that you don't waste DataDirect
>>>> processing/bandwidth.  My guess is that you've got a video source you
>>>> don't know about that's not connected to anything (and therefore has
>>>> no
>>>> channels) or you've specified DataDirect as the grabber type for a
>>>> video
>>>> source that should be set to "No grabber" or "EIT only".
>>> If the video source setup is broken it is well hidden!
>>> I have a PVR500 and an HDHomeRun. I did the 'delete all and recreate'
>>> thing not too long ago, when I took the HD3000 card out of the box.
>>> Same
>>> 2 video sources since forever...connected to the same pair of PVR
>>> tuners
>>> and now the HDHR...
>>> I have a backup copy of the mythconverg database here.  When I open it
>>> with myth, I cannot see anything in it which would lead me to think
>>> there was a phantom source.  In particular, not in Video Sources or
>>> Input Connections.
>>> However, I now notice that the card numbering for the PVR and HDHR are
>>> NOT 1,2,3,4, but 2,3,4,5.....So I probably selected 'delete all on this
>>> computer', and not 'delete all cards'...
>>> Silly me....Failure of the nut holding the wheel. I will do that again,
>>> properly, and check after doing so, that the database has been
>>> thoroughly cleansed...
>>> Interesting that mfdb run directly does not do the same thing? So mfdb
>>> run automatically adds command line switches invisibly?...Such as
>>> --remove-new-channels..I thought that we were supposed to do that
>>> within
>>> Setup.
>> Another thing that can cause this problem is having the pvr and hdhr use
>> the same lineup. The hdhr having only a small subset will delete the
>> "unused" channels from lineup. What I ended up doing was creating
>> another zap2it user and a duplicate lineup setup which keeps them from
>> interfering with each other.
> The tuners do NOT use the same lineup. One lineup analog, one digital.
> There should have been no overlap, but Rogers Cable is clearly
> double-casting 3 channels, once as analog and once as digital, since
> zap2it has those 3 with the same xmltvid ( and, viz. another thread, the
> same callsign). But the presence of the 3 channels should not trigger
> the removal of the another 32 analog channels.
> More testing required, obviously...
> Geoff

If the front and back end share the same box, check /etc/hosts to make
sure the line  localhost

is in there. I recently found it wasn't on mine (MythDora 3.2) and that I
had intermittent mythfilldatabase failures.

I'll post at more length separately about this.

Lan Barnes

SCM Analyst              Linux Guy
Tcl/Tk Enthusiast        Biodiesel Brewer

More information about the mythtv-users mailing list