[mythtv-users] permisions for /directory

Damian Surr damian at gingermagic.co.uk
Wed May 9 13:22:56 UTC 2007

William Munson wrote:
> Damian Surr wrote:
>> Hello all,
>> I set up a fresh Ubuntu install a couple of weeks ago ready for Myth and 
>> finally got the time to install myth last night. All went well apart 
>> from myth not having write access to the directory I've given to it.
>> When I set up the partitions, I created a separate partition called 
>> 'stuff' which Ubuntu mounts quite happily. I'll be putting all my media 
>> and downloads in here.
>> The mythtv section will be:
>> /stuff/media/mythtv
>> and in the backend setup, I set the recordings location to be
>> /stuff/media/mythtv/recordings
>> when I finished the setup, I was told that myth couldn't access that 
>> location.
>> I searched the net and found
>> sudo chmod -R username /directory
>> and ran
>> sudo chmod -R myname /stuff
>> which gave me the ability to create directorys in /stuff, so I created 
>> the 'media', 'mythtv' and 'recordings' directorys.
>> Myth still couldn't access them, so I tried:
>> sudo chmod -R mythtv /stuff
>> but is still didn't work. tried:
>> sudo chmod -R myname /stuff/media/mythtv
>> but still didn't progress. What am I doing wrong?
> The commands above do nothing for you. Two ways around this, either make 
> the direcotories writable to everyone by:
> chmod -R 777 /stuff/media
> or change the owner of the directories to mythtv by:
> chown -R mythtv:mythtv /stuff/media
> The first is a bit of a security risk but for the average home user 
> behind a router/firewall its safe enough. The second may give you 
> troubles if you want to write to the files with a different user. 
> Personally I would use the first option.
Thanks for the responces. This is what I did:

sudo chown -hR username /stuff
sudo chown -hR mythtv /stuff/media/mythtv
sudo chmod -R 772 /stuff

In the end, maybe I only needed that last line.
All seems well now with that problme now, except now my frontend can't 
connect to the back end! Why the hell should anything have changed 
there? It was fine last night.

Any ideas? I don't think I've changed anything that could cause that, 
but I'm getting the "Can't connect to back end. Are you sure it's 
running? Are you sure the IP address is correct" .. the answer to both 
of those is yes.

Damn, the was working so well ...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070509/78b01878/attachment.htm 

More information about the mythtv-users mailing list