[mythtv-users] Problems with new tunerless slave backend

Brian Guilfoos mythtv at guilfoos.com
Thu May 3 23:39:58 UTC 2007

Justin The Cynical wrote:
> Brian Guilfoos wrote:
>> Only for playback.  AFAIK, backend operations (commflagging,
>> transcoding, userjobs) require the file to be on a mounted filesystem.
>> To use this other machine to process video, NFS export /mythtv/storage
>> from your master backend, and mount it on your slave backend.
> And that did it, thanks.
> Now to figure out why I can't read the mounted file system if the NFS 
> export on the server goes away for any reason.[1]
> [1] Really strange...  wasn't able to get it to work via autofs,
>      added to fstab, worked.  Had it mounted, had to reboot the master
>      backend, trying to ls on the mount point on the slave returned
>      a 'permission denied'.  Remount it, it's fine.  I'm forgetting
>      some basic NFS thing, I know it.  :-P

Sometimes it takes a little while for the remount to happen
automatically, but that wouldn't be a "permission denied."  (For a while
I had kernel panics on my fileserver...)

/etc/exports on server:

/etc/fstab on backends:   /home/mythtv/data       nfs
bg,hard,intr,tcp,nfsvers=3,rsize=32768,wsize=32768,noatime,actimeo=0    0 0

I can't even remember how I worked up those parameters for mounting - I
suspect a lot of it was culled from this list, plus some
trial-and-error.  Works For Me (tm)!

More information about the mythtv-users mailing list