[mythtv-users] Issues with DVD drive

Lan Barnes lan at falleagle.net
Thu Mar 29 16:57:49 UTC 2007

I'm a relatively new Myth user running MythDora 3.2 whth a PVR-150 and an
old GForce nVidia card. The basics (watch TV, schedule recordings) are
running beautifully. Now I'm expanding my ambitions.

My problem is that the DVD functions appear not to be utilizing my DVD
R/W. The device is:


The system has linked /dev/dvd to /dev/hdd. This appears to be correct,
because when I run "eject /dev/hdd" as root, the tray opens. I also
installed MythDora through this drive (although it wouldn't be the first
time for me that a Fedora/RH install had recognized a drive that the
subsequent system couldn't see -- go figure).

My only other meaningful experiment was to put a known-good DVD movie in
the tray and select Play DVD in the menu. This led to a clearing of the
screen as if xine had loaded full screen, and then ... nothing. Healthy
looking disk access lights but nada. Ctr-Alt-F2 took me to another
terminal, so Linux was thriving under the hood, but I had to do a reboot
to get control back (obviously I could have played with various kills, but
a reboot seemed safe).

The system has:


So I don't syspect it's a decoding issue.

I googled the drive and found some commentary on how it may not be an
ideal HW choice for Linux, but can be made to work. I have put an
extensive quote below on this from what I found (skip if you wish).

So my questions:

- anyone know why this is happening?

- anyone have experience with this DVD HW?

- any recommendations? Upgrade the firmware? Cut my losses and buy a
different drive? Is it all user error?

TIA for any help.

*** beginning of quote


I purchased the LG GSA-4120b dual layer DVD+/-RW/RAM drive in September
2004 for $99 Cdn. As soon as I took it home, I discovered that it had
defective firmware (did not read commercial DVDs). The retailer exchanged
it for a new unit, which has worked fine so far. I am using it with
Kanotix 2004-05 (kernel 2.4.26-mppe-ar) and IDE-SCSI emulation
('append=hdc=ide-scsi' in lilo.conf).

The GSA-4120b can read and write to DVD-RAM media, which sets it apart
from other drives at its price-point in the market. Further, after I
hooked it up to /dev/hdc, it identified itself to Linux (cdrecord
-scanbus) without any additional software. However, I discovered that, as
with older LG models, the GSA-4120b DMA must be set to mdma2 in order to
successfully record to DVD+/-R media. As root, use the command: hdparm -d
1 -X mdma2 /dev/hdx (where /dev/hdx is the correct device ID eg. hda -
primary IDE master; hdb - primary IDE slave; hdc - secondary IDE master;
hdd - secondary IDE slave). You can put this command in your rc.local or
bootmisc.sh init script so that it executes every time you boot. MDMA2
does not seem to significantly affect DVD playback.

The GSA-4120b seems to be very fussy with media brands, especially if the
firmware is not recent. The current firmware version as of this post is
A111. Unfortunately, the firmware installation software is Windows only.
If you do not dual-boot into Windows, you can install the firmware by
using a Windows Live CD built with Bart's PE and Windows 2003 Server
180-day evaluation version (available for free download from Microsoft,
but requires registration).

Anandtech reviewed the GSA-4120b and tested its speed and ability with
different types of media. Overall, they concluded that it worked better
with DVD+R than DVD-R.

Here are my own impressions of GSA-4120b compatibility with various media

Commercial DVDs: no problems watching DVDs. The GSA-4120b is a pretty
quiet drive, too.

CD-R: no problems reading or writing to CD-R's. I don't use CD-RW, so I
can't comment on that.

Generic 4x DVD+R, DVD-R ($9.95 Cdn for spindle of 25): dvdrecord and
growisofs both seem to dislike generic DVD media. I've had the best
success using cdrecord-ProDVD, which hasn't coastered yet. Unfortunately,
cdrecord-ProDVD is not Free Software; it is available free (of cost) for
personal use, but you have to periodically download a time-limited key.
Also, when you purchase generic DVD media, look carefully for the
manufacturer's code, in small print near the centre hole. On the DVD-R,
the code is FW0B; on the DVD+R media, the code is FW1B. My retailer says
that in general, "FW" media works with LG drives, and "GW" media doesn't.

BenQ 8x DVD+R, DVD-R: these were on sale at Future Shop, $4 Cdn for
package of 5, so I thought what the hell. However, they are like generic
media, and tend to coaster.

Verbatim "Digital Movie" DVD+R ($20 Cdn for package of 5): after much
frustration and coastering with generic media, I splurged and purchased
Verbatim, which did the best in the Anandtech review. I've burned one
Verbatim DVD+R with cdrecord-ProDVD, and another with k3b (which uses
growisofs from the dvd+rw-tools package). Both were successful. I guess
you really get what you pay for.

Maxell DVD-RAM ($9 Cdn each): works fine; I'm still exploring DVD-RAM
issues. I came across this piece of advice: in your /etc/fstab, ensure
that you use the 'noatime' option for the DVD-RAM drive, otherwise you
will quickly wear out the read-write cycles for the medium eg. /dev/hdc
/mnt/dvd auto users,exec,noatime,noauto,rw 0 0

2004-12-20 update: I love DVD-RAM. It's like a giant floppy. All I needed
to do to format it was use the mkfs command -- see the above
linuxquestions.org thread.

Dual-layer: no affordable dual layer media is available yet, so I will
have to wait before I can see if the GSA-4120b performs as advertised.

I don't have any opinion about drive speed, because I don't care about the
difference between 2x or 4x or 8x or whatever. Read the Anandtech review
if you're interested.

I'm giving the GSA-4120b a 5/10 rating for Linux compatibility mainly
because the firmware installation software is Windows only. Otherwise, the
drive works with Linux, provided that you buy good quality recordable DVD

*** end of quote

Lan Barnes

SCM Analyst              Linux Guy
Tcl/Tk Enthusiast        Biodiesel Brewer

More information about the mythtv-users mailing list