[mythtv-users] 7.1 channel audio

Al McIntosh junkmail at allanmcintosh.com
Wed Mar 28 00:44:32 UTC 2007

Bill Williamson wrote:
> On 3/10/07, Al McIntosh <junkmail at allanmcintosh.com> wrote:
>> Hey,
>>    I have a Sound Blaster Live! card connected to 7.1 amp via optical
>> coax cable. When I watch DVDs or anything with xine I get nice, rich
>> full surround sound. However, when I watch recorded shows within mythtv
>> there is no output from LS or RS. The front , center and rear channels
>> all output.   Is this a shortcoming of my current version
>> *mythtv-0.20-153.fc6.at*? With the below .asoundrc I set playback to
>> ALSA:default.  Any ideas?
> Your card does not support realtime dolby digital encoding.  You get
> surround from DVDs because it is passing through the stream directly.
> When watching TV, it sends a PCM stereo signal as that is the best the
> card can produce from scratch.  Your receiver is smart enough to go
> into "pro logic" mode, and it invents front and rear channels from the
> stereo signal.
> THere are a few cards on the market that do real time surround
> encoding, but I do not know how linux support is for them.

The part I don't understand is, my SD Satellite receiver is connected to 
the same audio receiver via RCA cables and the receiver can up convert 
that input and produce sound in all 8 speakers. The recorded shows 
played back in Myth are from the same source but when passed via spdif 
the side channels are mute, the audio for both is from the same source.

More information about the mythtv-users mailing list