[mythtv-users] Slow frontend response after upgrade

Jeffrey Born jeff.born at gmail.com
Tue Mar 27 00:47:02 UTC 2007


My latest problem is a slow GUI response inside of mythtv.  Everything else
that I use works fine.  I know the response rate is slow because I've seen
it when it was working correctly, but then decided to do a upgrade via yum.
I run the following set of yum command under fc6:

yum --disablerepo=atrpms -y update
yum --enablerepo=livna -y update kmod-nvidia
yum -y update mythtv-suite
yum install ivtv ivtv-kmdl-`uname -r`
modprobe ivtv

That seems to be my standard upgrade script and has worked for a couple of
upgrades.  Third one is a charm right?  In my case everything seems to work
until I get to mythfrontend.  At that point I have a very slow response.  I
can actually see the screen paint, and for a GeForce 6600 GT on and AMD x64
3000 with under a 5% load that just isn't right.

I've verified that I'm using the nvidia drivers.  The configuration screen
says Open GL is in use.  My method of verification is very unscientific.. I
make sure that a nvidia splash screen shows up before the login screen is
displayed, so if there is a better way please let me know.

At first I had a post on fedoraforums about not using the nvidia driver
after the upgrade by default.  They walked me through that, but are not sure
why my screen refresh would be slow.

So my question is any idea how to get the mythfrontend working snappy again?

I'll post a few of the debugging pieces I know about.  I'll be happy to post
more if it will help debug what is going on.

kernal version: 2.6.20-1.2925.fc6

contents of xorg.conf:
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1280x1024" "1280x960" "1280x960"
"1280x800" "1280x800" "1152x864" "1152x864" "1152x768" "1152x768" "1024x768"
"1024x768" "800x600" "800x600" "640x480" "640x480"

END xorg.conf

rpm -q kernel kernel-devel kmod-nvidia

That all the information I know to provide.  I'll be happy to post more to
help debug this.

PS I know the moral of the story is if its not broke don't fix it, but half
my desire to get mythtv working is to learn a lot about linux.  If I don't
upgrade and break things I'll never learn how to fix it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070326/a22137fb/attachment.htm 

More information about the mythtv-users mailing list