[mythtv-users] Problems with imdb.pl

Stroller linux.luser at myrealbox.com
Sun Mar 25 01:20:57 UTC 2007

Tamir Alush wrote:
> Running the IMDB script on a movie name which has more than one  
> word in its title, gives out no results. I have to add a backslash  
> (\) before the second and third words in order to get the IMDB  
> title number in return. For example: "imdb.pl -M Running Scared"  
> returns nothing, but if I type "imdb.pl -M Running\ Scared" I get  
> the correct IMDB title number.

Hi there,

You're putting quotes around the command you tried when posting here  
- have you tried using quotes in the command?


    imdb.pl -M "Running Scared"


This should tell the shell to pass "Running Scared" to imdb.pl as a  
single parameter, rather than two separate ones.


PS: When posting questions & answers to mailing lists I usually like  
to use `single quotes` to indicate short commands. In longer output I  
use a dollar or hash, like you'd see a shell offer if you started it  
with the most simple environment.

$ whoami
$ su -
# whoami

I believe this is clearer because it's the same quotation syntax you  
would use with the shell itself. For instance:
$ for foo in `cat movies.txt` ; do imdb.pl -M "$foo" ; done

More information about the mythtv-users mailing list