[mythtv-users] mythbackend undefined symbol

David Highley dhighley at highley-recommended.com
Tue Mar 20 01:32:24 UTC 2007

"Mike Perkins wrote:"
> R. G. Newbury wrote:
> > David Highley wrote:
> >> "Mike Perkins wrote:"
> >>> David Highley wrote:
> >>>> "David Highley wrote:"
> >>>>> Using svn mythtv version 13058 I'm getting a run time undefined error:
> >>>>> [root at douglas ~]# service mythbackend restart
> >>>>> Stopping mythbackend:                                      [FAILED]
> >>>>> Starting mythbackend: /usr/local/bin/mythbackend: symbol lookup error:
> >>>>> /usr/local/bin/mythbackend: undefined symbol: _ZN4UPnp9g_pConfigE
> >>>>>
> >>>>> Compiles without any indication of a problem.
> >>>> I turned off optimization on the compile and that did not solve the
> >>>> issue. Using nm it appears that the undefined symbol should be defined
> >>>> by code in mythtv. That is a guess based on other symbols in myth
> >>>> libraries.
> >>> Had one of these: it is probably an old library lying around somewhere. 
> >>> Try a make distclean, also look for libmyth* files in places like lib64.
> >> I had done make distclean and removed the entire mythtv svn tree and
> >> down loaded it again. I ran a locate and found that the mythtv build
> >> process was now putting the libraries in the /usr/local/lib64 directory
> >> so I ended up needing to modify the /etc/ld.so.conf.d/local.conf file to
> >> add another line /usr/local/lib64 before the /usr/local/lib line and
> >> then run ldconfig to update the cache file. Works now, thanks.
> > 
> > 
> > This looksvlike something which should be added to the proper spot in 
> > the wiki. It depends on the distro etc. so I cannot tell where it should 
> > go. Would one of you (OP or Responder) please do that?
> > 
> > Geoff
> > 
> > 
> Actually the situation is slightly worse than that. When I first 
> downloaded 0.20-fixes from SVN and built it, I was slightly startled to 
> find that, although it built, it could not identify any means of 
> outputting video.
> After much tearing of hair, etc I spotted the libraries gotcha mentioned 
> above, and thought: why? I've just built a 64-bit system, why can't it 
> find XVMC? The libraries are plainly visible in lib64.
> On closer inspection of ./configure, there's a function called 
> 'has_library()' which is supposed to find these things. This is coded in 
> such a way it will only look in either <path>/lib or <path>/lib64, not 
> both. I am running Mandriva 20070, so this (for me, at least) may be a 
> distribution-specific issue. The fix David gave above also worked for 
> me, but is this the sort of thing the user should have to do? Or should 
> the configure script be updated for this variation as it is for many 
> other distro specifics? Alternatively, is this just a Mandriva peculiarity?

You need to add the configure option -libdir-name=lib64

> Mike Perkins
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list