[mythtv-users] mythbackend undefined symbol

R. G. Newbury newbury at mandamus.org
Mon Mar 19 18:05:49 UTC 2007

David Highley wrote:
> "Mike Perkins wrote:"
>> David Highley wrote:
>>> "David Highley wrote:"
>>>> Using svn mythtv version 13058 I'm getting a run time undefined error:
>>>> [root at douglas ~]# service mythbackend restart
>>>> Stopping mythbackend:                                      [FAILED]
>>>> Starting mythbackend: /usr/local/bin/mythbackend: symbol lookup error:
>>>> /usr/local/bin/mythbackend: undefined symbol: _ZN4UPnp9g_pConfigE
>>>> Compiles without any indication of a problem.
>>> I turned off optimization on the compile and that did not solve the
>>> issue. Using nm it appears that the undefined symbol should be defined
>>> by code in mythtv. That is a guess based on other symbols in myth
>>> libraries.
>> Had one of these: it is probably an old library lying around somewhere. 
>> Try a make distclean, also look for libmyth* files in places like lib64.
> I had done make distclean and removed the entire mythtv svn tree and
> down loaded it again. I ran a locate and found that the mythtv build
> process was now putting the libraries in the /usr/local/lib64 directory
> so I ended up needing to modify the /etc/ld.so.conf.d/local.conf file to
> add another line /usr/local/lib64 before the /usr/local/lib line and
> then run ldconfig to update the cache file. Works now, thanks.

This looksvlike something which should be added to the proper spot in 
the wiki. It depends on the distro etc. so I cannot tell where it should 
go. Would one of you (OP or Responder) please do that?


              R. Geoffrey Newbury			
            Barrister and Solicitor
       Suite 106, 150 Lakeshore Road West
          Mississauga, Ontario, L5H 3R2

         o905-271-9600 f905-271-1638
           newbury at mandamus.org

        Helping with the HTTP issue
<a href="http://www.w3.org/Protocols/">HTTP</a>

More information about the mythtv-users mailing list