[mythtv-users] backend crashing

Mark Knecht markknecht at gmail.com
Fri Mar 16 19:04:48 UTC 2007

On 3/16/07, Sreeram Kumar <Sreeramkumar at yahoo.com> wrote:
> Hi,
>   My backend crashes sometimes with the below kind of
> a message. Any way to avoid this? Please let me know.
> Thanks,
> Sreeram
> *** glibc detected *** /usr/bin/mythbackend: malloc():
> memory corruption (fast): 0x09487c4f ***
> ======= Backtrace: =========
> /lib/libc.so.6[0xa9e5eb]
> /lib/libc.so.6(malloc+0x73)[0xa9f7f4]
> /usr/lib/libstdc++.so.6(_Znwj+0x27)[0x31bcbb7]
> /usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN6QGList7prependEPv+0x3d)[0x672495d]
> /usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN6QGList8insertAtEjPv+0xe7)[0x6724aa7]
> /usr/lib/qt-3.3/lib/libqt-mt.so.3[0x6425f4a]
> /usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QObjectC2EPS_PKc+0xa7)[0x6426177]

   I have seen similar problems here. I reported it and was told it
was probably the system overheating. To look at that I switched from
an SMP to UP kernel and the occurrences of this problem did decrease.

   I have never seen any app other than mythbackend crash so it still
seems suspect to me. I reported that the main time tis happens is when
I am deleting a recording from a specific remote machine. I got no
comment back on that one.

   Consider looking at your fans and airflow around the machine. There
are a lot of time when I see mythbackend essentially using 100% CPU so
heating could be an issue.

Hope this helps,

More information about the mythtv-users mailing list