[mythtv-users] USB-UIRT under FC6 and lirc 0.8.2 ?

Mark Abreu mark at gags-r-us.org
Sat Mar 10 03:19:42 UTC 2007

 On Fri, 9 Mar 2007 10:37:05 -0500, Dan Wilga wrote:

> I have it working both as a receiver and a transmitter (it's the latter that
> requires newer versions of LIRC.) What, specifically, doesn't work? How far
> do you get? --

Per the Jarod Wilson MythTV how-to I did this:

# yum -y install lirc-kmdl-$KVER
# yum -y install lirc 

I edited /etc/modprobe.conf to add this line, which was an educated guess:

alias char-major-61 lirc_usb-uirt2_raw

I picked up the "lirc_usb-uirt2_raw" by googling but have no idea if it's correct.

To get the drivers automatically loaded at boot time I did this:

# cd /etc/sysconfig/modules/
# wget --no-check-certificate https://svn.wilsonet.com/svn/mythtvology/trunk/lirc.modules
# chmod +x lirc.modules 

Next I tried to start lirc:

# /sbin/service lircd start

I didn't get any message at all.  When I look in /var/log/messages I don't see anything about lirc.  So I went ahead and tried to test it and got an error:

$ /usr/bin/irw 
connect: No such file or directory

I rebooted and nothing seemed to change.

When I went searching for lirc modules I see these and don't see one that looks like it's for the USB-UIRT.


I may need to go to the lirc list for help.  I suspect right now that the lirc stuff I got from atrpms.net may not have usb-uirt support or that I'm missing some things in the modprobe.conf file.


More information about the mythtv-users mailing list