[mythtv-users] /dev/video0

Rod Smith mythtv at rodsbooks.com
Mon Mar 5 17:00:37 UTC 2007

On Monday 05 March 2007 11:11, David Lynam wrote:
> > On Monday 05 March 2007 09:41, David Lynam wrote:
> > > Hi,
> > > I have a bit of an issue, i had mythtv up and running on both a
> > > frontend/backend and seperate frontend machine and it worked fine.
> > > I then 
> > > tried to include a new XBOX frontend. While trying to get the XBOX
> > > using the PC monitor and trying to scan for AV i seem to have deleted
> > > the file /dev/video0 (may have been some elses doing).
> > >
> Its ubuntu edgy 6.10! the file is for the capture card ivtv 150! When I go
> into the settings in mythtv and go into the capture card option and it says
> failed to open file! i cant see the file in /dev! i have rebooted a few
> times with no luck?

Ubuntu uses udev, so it should be detecting all hardware for which you have 
drivers, assuming you've not damaged your udev configuration too badly. You 
still haven't summarized what you've attempted to do when configuring your 
Xbox frontend, so I can only make some guesses about what might have gone 
wrong, and how these problems might be fixed:

1) The card could have become dislodged. This is most likely if you opened
   the case for any reason. You can turn off the power, pull the card, and
   reseat it to fix this.

2) The card may have been physically damaged. If so, you'll need to replace

3) If you touched any of the files in the /etc/udev directory tree, udev may
   not be working correctly. If you think you may have done this, you'll
   need to get some working replacement files (from the udev package or
   various others, depending on what's damaged or missing).

4) If you messed with any of the driver files in /lib/modules, you may need
   to replace them. There are actually two sub-possibilities here:
   a) If a kernel driver file has been removed or damaged, you'll have to
      replace it. You can do this by re-installing an appropriate package,
      such as linux-image. If you've compiled your kernel yourself, you'll
      need to recompile it and run "make modules_install" again.
   b) If I'm not mistaken, the ivtv drivers come as a separate package.
      If you removed or damaged an ivtv driver, you'll need to replace that

5) If you recompiled your kernel, you may have omitted some necessary
   drivers. If you can still boot an old kernel, try that; or you can go
   through your kernel options to figure out what you omitted that's
   important and add it back.

6) You could have removed or damaged the firmware for the card. The
   firmware files are probably stored in /lib/firmware. If this is the
   source of the problem, you'll need to replace the firmware. Consult
   the ivtv documentation for details.

7) You could have created a local startup script that deletes the /dev/video0
   device file. You'd probably be aware if you'd done this, though; I
   mention the possibility only for the sake of completeness.

These are the possibilities that spring to mind, but there are almost 
certainly others.

You may be able to obtain additional clues from dmesg output or log files in 
the /var/log directory tree (/var/log/messages is the most likely to hold 
important clues). Try typing "dmesg | less" at a command prompt, then paging 
through the output looking for any messages from ivtv drivers or relating to 
video devices. (Some of these may relate to your video card, though.) There 
may be a clue, such as a message about firmware not being found. If you see 
no messages relating to your video card, then it means that either the 
drivers aren't present or they can't find your hardware (in other words, 
options #1, 2, 4, or 5 above).

Another diagnostic tool is "lsmod", which lists your kernel modules. Pipe it 
through less ("lsmod | less") or use grep to search for anything related to 
your ivtv drivers ("lsmod | grep ivtv", assuming your drivers show up 
as "ivtv"). If you don't see any references to your ivtv drivers, then they 
aren't loading for some reason (or are built directly into your kernel, but I 
don't know if that's possible for the ivtv drivers).

A final useful diagnostic is typing "lspci | less". Among the output you 
should see something about your video capture card. If you can't spot 
anything, then chances are good the card has been damaged or isn't properly 

Rod Smith

More information about the mythtv-users mailing list