[mythtv-users] /dev/video0

Rod Smith mythtv at rodsbooks.com
Mon Mar 5 15:28:54 UTC 2007

On Monday 05 March 2007 09:41, David Lynam wrote:
> Hi,
> I have a bit of an issue, i had mythtv up and running on both a
> frontend/backend and seperate frontend machine and it worked fine. I then
> tried to include a new XBOX frontend. While trying to get the XBOX using
> the PC monitor and trying to scan for AV i seem to have deleted the file
> /dev/video0 (may have been some elses doing). I am stuck in a rut here as
> it will allow me to do nothing sayin this cant access this file. I can see
> the file is missing?? how can I get in back and get some live tv goin
> again?? Please help stress is killin me :)
> David

First, what distribution are you using? If it's something recent, it's 
probably using udev, which is a way for Linux to automatically create device 
files when the system boots or when device driver configurations change. If 
this is so and if you've just accidentally type "rm /dev/video0" or something 
similar, you should get your device file back by rebooting the computer.

Assuming it's not that simple, you must have somehow configured your system to 
not load the relevant driver. The fix will depend on how you did this, and 
perhaps on what driver it is, and thus what hardware (particularly your 
encoding device) you're using, so please post your hardware information. Some 
clues about what you did to your backend in your experimentation would be 
helpful, too; I can think of several very different ways you could have 
caused your /dev/video0 device to go away, and the fixes will be equally 

Rod Smith

More information about the mythtv-users mailing list