[mythtv-users] Remote Frontend HD playback causes Segfault

Mike LaPlante mike at dividia.net
Sat Jun 30 20:00:23 UTC 2007

I can't for the life of me figure this one out. I'm running F7 on both 
my backend and frontend. My backend (though its the lesser power 
machine) plays back HD content just fine. But my beefier frontend 
segfaults within the first 30 seconds of playback. It seems to vary, 
sometimes I get the segfault immediately, sometimes I think its finally 
going to work then boom.

I need some guidance on what to try, I've changed interlacing, with and 
without opengl timing, even tried XvMC thought this machine shouldn't 
need it. I've tried several nvidia drivers (currently using 100.14.11). 
I don't think its a driver issue because X is not crashing, just 
mythfrontend is crashing. Also playback of SD stuff works fine, 
mythfrontend can run for days perhaps for eternity as long as I don't 
try to play back an HD clip.

Currently running ATrpms-bleeding SVN revision 13756. I suppose I could 
try building from source and enabling the debug stuff. But I was hoping 
someone had a few hints before I went through that.

I do have one clue, earlier I believe artsd was using /dev/dsp for 
whatever reason so when I tried to play an HD clip I got an message 
saying it was disabling audio. Well, the clip played fine after that, 
except the obvious no sound, but at least it didn't segfault. So..... 
I'm tinkering with the audio buffering options.


More information about the mythtv-users mailing list