[mythtv-users] Ahh - Evil xorg and modelines

Alan Calvert cal at graggrag.com
Sat Jun 16 14:28:20 UTC 2007

Damian Surr wrote:
> Steve Smith wrote:
>> Damian,
>> I did a bit of reading. Maybe if you were to go right back to basics and 
>> see what the NVIDIA can do on its own:
>> 1) Get rid of the modelines.
>> 2) Try specifying the resolution as "1024x768_60" in the "Modes" line. 
>> The EDID suggests the monitor will support this.
>> 3) Don't put any of those "NoEDID" options etc in there, let's just see 
>> if the NVIDIA can sort it out itself!
>> 4) Don't specify the horizontal and vertical frequency limits either 
>> just see what the EDID gives us...
>> Do the startx --logverbose 5 thing and see what happens....
> Right Steve, I did that.

You still don't have a _valid_ 1024x768 mode line. Try going even one step
simpler ...
Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV34 [GeForce FX 5200]"
    Monitor        "BenQ W100"
    DefaultDepth    24
    Option         "metamodes" "1024x768 +0+0"
    Subsection "Display"
        Depth       24
        Modes       "1024x768" # Note, just "1024x768", no fancy frequency specification!

And when you post your next log, please consider pruning it first (especially
if you're going to post it multiple times!). All that's relevant for now is
from ...
  > (II) Setting vga for screen 0.

down to ...
  > (WW) NVIDIA(0): BenQ W100 (DFP-0)'s EDID does not contain a maximum image
  > (WW) NVIDIA(0):     size; cannot compute DPI from BenQ W100 (DFP-0)'s EDID.
  > (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
  > (--) Depth 24 pixmap format is 32 bpp
or thereabouts. Lose the rest.


More information about the mythtv-users mailing list