[mythtv-users] X.org 7.2 support

Khanh Tran khanh at khanh.net
Fri Jun 15 17:28:23 UTC 2007

On 6/14/07, Khanh Tran <khanh at khanh.net> wrote:
> On 5/21/07, Neil Milne <neil.milne at gmail.com> wrote:
> >
> > Hmm, I'm not hitting this particular issue - my display size is set
> > correctly. I'm running gentoo with the latest ebuilds for xorg
> > (xorg-x11-7.2 and xorg-server- Perhaps that's an issue with
> > only some drivers? I'm using the proprietary nvidia driver and have it
> > set to ignore all EDID config which might prevent me from seeing the
> > display size issue, since the bug reports all say that the DDC values
> > are used to override the display.
> >
> I'm using the SIS video driver and I can't get X to use my settings.  (I
> started another thread about this):
> I recently rebuilt my myth box, and went from SuSE 10 to 10.2.  The issue
> I'm having now is with the dpi.  xdpyinfo reports:
>  dimensions:    1280x768 pixels (40x30 millimeters)
>   resolution:    813x650 dots per inch
> even though I set my DisplaySize to 352 182

I just found a nice workaround to this issue, until SuSE releases an
updated driver/xorg 7.2.

In MythTV setup, go to Appearance, in VIdeo Mode Settings, enable
"Separate video modes for GUI and TV playback".  I set GUI and Video
Output, both to 1280x720 and most importantly, Aspect to 16:9.

In xorg.conf (to correct font oversize issues), I enabled Option "DPI"
"100 x 100".

This corrects the aspect ratio issues when your driver ignores your
specified dimensions.

More information about the mythtv-users mailing list