[mythtv-users] Database version

Michael T. Dean mtdean at thirdcontact.com
Wed Jul 25 16:31:21 UTC 2007

On 07/25/2007 04:09 AM, Lee McLaren wrote:
> Is there a table somewhere that shows what svn revision or version has
> what database version?

There's much more than DB schema version that must be identical for two
differing revisions to work together.

> I am trying to run minimyth with the current svn trunk and the trunk is
> using 35 and minmyth wants 31

Including protocol version (and 31 and 35 are protocol versions--DB
schema versions are around 1100-1200).

Though it's of no direct help, I refer you to:
and, specifically, the part about, "If you do try to mix and match
revisions or branches of MythTV code, debugging problems is your own
responsibility."  (And, see, also, the "Slightly longer answer" part.)

The right solution is to find an up-to-date version of minimyth that's
compiled against a revision of 0.20-fixes SVN and then compile your
backend to use 0.20-fixes SVN of the same revision.  If you have to use
the bleeding edge development version of Myth, then you should compile
the same revision of SVN trunk for your MiniMyth.  Both are left as an
exercise to the reader.


More information about the mythtv-users mailing list