[mythtv-users] MythArchive truncating video?

Joe Borne joe.borne at gmail.com
Mon Jul 23 12:52:21 UTC 2007


I have had trouble with MythArchive since I first set up my most
recent system. Since archiving isn't something I did very often I just
got around to fooling with it over the weekend.

Essentially, ffmpeg kept failing when it tried to run. First I was
getting the error where it tried to change the permissions in /tmp. So
I changed the archiving temp directory to /video/mytharchive/tmp
(mythtv:mythtv permissions). Then I was getting a segfault error after
it ran for 15-20 minutes. I tried it with several different
recordings/videos to make sure it wasn't a funky file problem.

So I tried removing and re-installing ffmpeg with yum (I'm running Fed
Core 6, and Myth 0.2 bleeding edge from ATRPMS). Still no dice.
Finally I downloaded the most recent snapshot ffmpeg source from the
mplayerhq.hu site and compiled. I did get an "error 2" at the end of
the "make install", but everything seemed to have installed properly.

Now when I run MythArchive, everything appears to run perfectly. But
when I play the resulting DVD, the video/recording is cut off after
3-6 minutes. I triple checked all my settings and I can't find an
explanation for this.

Can anyone help?


More information about the mythtv-users mailing list