[mythtv-users] Remote to turn *on* mythtv?

David Frascone dave at frascone.com
Tue Jul 17 19:20:50 UTC 2007

On 7/17/07, Leighton Brough <brough at baremetalsoft.com> wrote:
> Craig Huff wrote:
> > Problem:  I can't get my remote to wake up my system.  I want to be able
> to wake from the suspend-to-disk state, which I *think* is S4 (important
> that I have this right -- see below)
> >
> > Earlier in this thread Leighton reported that he was using the Microsoft
> MCE USB remote to wake his system from the suspend-to-RAM state.
> >
> > I have an Asus M2NPV-VM motherboard based system which I am still
> configuring and I have a (newly purchased) Microsoft MCE USB remote
> attached.
> >
> > I have all the mobo jumpers repositioned to supply standby power to the
> keyboard and the backpanel USB ports, where I have the MCE receiver
> attached.
> >
> > I *can* wake my system up with the keyboard I'm using while I set it up,
> but eventually it has to go ;-).
> >
> > I have turned on the BIOS setting for allowing/enabling PCI events to
> wake the system up.
> >
> > I have tried doing the following before suspending to disk:
> > #  echo USB0 > /proc/acpi/wakeup
> > #  echo USB2 > /proc/acpi/wakeup
> > #  echo PS2K > /proc/acpi/wakeup
> > and then suspending with (IIRC):
> > #  echo disk > /sys/power/state
> >
> > Since I plan to use Suspend2 (now called TuxOnIce! I think) and already
> have in installed, I tried that, too, after the three echoes to
> /proc/acpi/wakeup with:
> >   hibernate
> >
> > I've tried various keys on the remote and can see the receiver feedback
> LED respond, but the system stays off until I use the keyboard or front
> panel power switch.
> >
> > After performing the three echoes to /proc/acpi/wakeup, I get the
> following with this command:
> > # cat /proc/acpi/wakeup | grep enabled
> > PS2M    4    enabled
> > PS2K    4    enabled
> > USB0    4    enabled
> > USB2    4    enabled
> >
> > I interpret this to mean the USB ports, keyboard and mouse are all
> enabled to wake the system from the S4 state.
> >
> > Have I left any stones unturned or is this mobo doomed to not wake from
> S4 via this IR receiver?
> >
> >
> The only other stones I can suggest to turn are:
> The only button on the MCE remote which will wake the system is the
> power button. So make sure this is the one you are pressing. For me this
> is the only button which causes the receiver LED to flash when the
> system is suspended.
> Some time ago, using an earlier kernel (sometime before 2.6.18 - I
> forget which) I found I had to manually set the power state of the USB
> receiver then unload the USB driver module to prevent this from turning
> it off when suspending. I forget the exact files involved, but I think
> it was something like /sys/.../power. I guess it's unlikely this is your
> problem, but if you're trying to exhaust all possibilities it might be
> worth having a rummage in /sys too. Or for that matter you could try
> another kernel, since it seems the support for ACPI and power management
> continues to improve over time. Of course your kernel needs to be built
> with ACPI support too, but I don't think you'd see /proc/acpi if it
> wasn't.
> There's a kernel command line parameter called "acpi_os_name" which
> allows you to specify the name which the OS reports to the ACPI
> subsystem, which in turn may alter the behaviour of this. Try Googling
> for this, it might give you some ideas. Also, there are some ACPI
> support issues with Linux, due to the Microsoft versus Intel compiler
> being used to build the ACPI tables. Some folks have found they need to
> fix the ACPI tables to get features to work. Again, Googling for Linux
> and ACPI might give you some things to try.
> When I was first experimenting with this I temporarily installed Windows
> 2000 (or maybe it was XP) just to prove the HW worked OK. You can set
> the "allow this device to wake the system" option for the USB receiver,
> then hibernate and try the remote power button. This was (relatively)
> quick and easy to get going, and gave me the confidence to persevere
> with the required Linux config. That may be something else you can try.
> The only other thing I can think of to suggest is to try both enabling
> and disabling the BIOS setting for PCI event wakeup (I don't have this
> setting in my BIOS). But you've probably already tried that.
> For what it's worth, when I cat /proc/acpi/wakeup I also see state 4 for
> all devices, even though my system wakes from S3. I'm not sure the "4"
> means "S4" or the ACPI device power state the USB device will be put
> into on suspend (related to but different from the S1 - S5 system power
> states).
> Leighton

Is it possible to do this with  a serial receiver?  What if I get a usb
serial dongle?


David Frascone

Happiness is a warm modem
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070717/93848e1a/attachment.htm 

More information about the mythtv-users mailing list