[mythtv-users] Nvidia FX5200 with Westinghouse LVM-47w1

Jarod Wilson lists at wilsonet.com
Tue Jan 30 17:02:12 UTC 2007

Bill wrote:
> On Tue, 30 Jan 2007 07:34:08 -0800
> Brad DerManouelian <myth at dermanouelian.com> wrote:
>> On Jan 30, 2007, at 7:02 AM, Bill wrote:
>>> Prob #1)  I connected my FX5200 from my DVI to the DVI-2 connector  
>>> on the TV.  Everything looks perfect!  The desktop gives me no  
>>> issues, playback in myth gives me no issues, mplayer direct on the  
>>> screen is fine.  However, if I move through the menus in MythTV  
>>> quickly, it begins to get funky.  Basically it seems like the TV  
>>> goes and resets itself.  Then comes back.  There is a slight pop  
>>> from the speakers.  Once it starts happening, it happens each time  
>>> I move the selector in the menus.  If I go to a playback it does  
>>> not happen, or if I go back to the desktop its fine.  Only in the  
>>> myth menuing. (Which looks perfect by the way).  I tried turning  
>>> off OpenGL rendering and the same problem.
>>> Last night I had a dream.  I dreamt that during my unpackaging of  
>>> the LVM-47w1 I saw an paper insert that showed the two DVI ports on  
>>> the back of the tv.  In my dream one was indicated as being 1080i  
>>> and the other 1080p.  I call this a dream since I cannot for the  
>>> life of me find it.  Also, the manual shows both being 1080p.  But  
>>> the manual is for two models.
>> Assuming the 47 is the same as my 42,  DVI-1 is a dual-link DVI port  
>> supporting 1080p and DVI-2 is a single-link DVI port supporting  
>> 1080i. I upgraded to a dual-link nvidia 6600 card and changed my DVI  
>> cable and they went away. From what I understand I might have only  
>> needed to change the cable.
>>> Regardless, I swapped it over to DVI-1 and have not been able to  
>>> replicate the problem. But I did not have a chance to put it back  
>>> on DVI-2 (had to go to work).  Also, there may have been recording  
>>> going on last night, but not this morning.
>> You've probably got a single-link DVI cable.
> So maybe my dream was not just a dream....  If it keeps working fine, I will guess the output as 1080p on DVI-1 was the 
> solution. 

My 37" Westy's DVI-2 does not support 1080p either, only DVI-1 (and 
VGA). And I'm using a single-link DVI cable for 1080p w/o any problems.

>>> The log files are empty of any indication of a problem.
>>> Prob #2)  I am just throwing this in, since it is bothering me.  My  
>>> fading menus have gone away at some point last night.  It happened  
>>> sometime after I added in my FX5200 card and before I gave up for  
>>> the night.  Part of that was moving from the xorg "nv" driver to  
>>> the actual "nvidia" drivers.  In my STFW, I came across a  
>>> transparency tip.
>> To get the fades, you need to make sure the frontend is using OpenGL  
>> rendering (In the Appearance section of Setup) and make sure OpenGL  
>> is working on your card. This probably means using the nvidia driver  
>> as opposed to the nv driver but I'm not 100% sure of this. I just  
>> know that nv has never given me OpenGL.
> Definately got the nvidia driver running, and I think OpenGL is running...  I've got load "glx", the log file shows:
> (II) LoadModule: "glx"
> (II) Loading /usr/lib/xorg/modules/libglx.so
> (II) Module glx: vendor="NVIDIA Corporation"
>         compiled for 4.0.2, module version = 1.0.8776
>         Module class: X.Org Server Extension
>         ABI class: X.Org Server Extension, version 0.1
> (II) Loading extension GLX
> (II) Initializing extension GLX
> And no errors... when I was getting GL running before I had lots of errors.
> Also GLXGEARS runs fine - not sure if that is a positive indicator of a good OpenGL install?

It'll run w/software opengl rendering if hardware opengl isn't working, 
but it looks like you have hardware opengl there. So like Brad says, 
make sure you're using the OpenGL painter.

>>> Section "Monitor"
>>>     Identifier     "Westinghouse"
>>>     VendorName "Westinghouse"
>>>     ModelName "LCD Panel 1920x1080"
>>>     HorizSync 31.5 - 90.0
>>>     VertRefresh 60.0 - 60.0
>>>     ModeLine "1920x1080p" 148.5 1920 2024 2072 2200 1080 1084 1094  
>>> 1124 -hsync -vsync
>>>     Option "ModeValidation" "NoMaxPClkCheck, NoEdidMaxPClkCheck"
>>>     Option "dpms"
>>> EndSection
>> Once you get your hardware sorted out, you probably won't need a  
>> modeline. I don't have one and my display looks perfect. (One of the  
>> joys of getting a "display" as opposed to a HD-TV - no overscan).
> I had tried it without the modeline, and had problems - but that was on the other DVI(2) and could have been with different other settings that were causing problems.

I'll have to try w/o a modeline one of these days myself....


More information about the mythtv-users mailing list