[mythtv-users] compilation problems on svn-0.20-fixes

Rudy Zijlstra mythtv at edsons.demon.nl
Mon Jan 29 14:04:13 UTC 2007

Steven Adeff wrote:
> On 1/28/07, Rudy Zijlstra <mythtv at edsons.demon.nl> wrote:
>> Rudy Zijlstra wrote:
>>> Hi,
>>> After forcing configure with --cpu=i686 (see previous email) i get the
>>> following compilation error:
>>> ccache gcc -c -pipe -march=pentiumpro -w -O3 -Wall -Wno-switch
>>> -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -DUSING_FREEBOX
>> <snip>
>> Solved this one. On slackware-current this fails. On slackware-11.0 it
>> goes well.
>> Solved it by re-installing the machine down to slackware-11.0
>> Rudy
>> P.S. the processor is still not correctly detected.
> any reason your using --cpu instead of --enable-proc-opt ?

see below:
 ./configure --disable-distcc

 *** WARNING ***
 Your CPU was not detected properly:
   uname -m: i686
   uname -p: prescott
 model name: Intel(R) Pentium(R) 4 CPU 3.20GHz
      flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca 
cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe 
constant_tsc pni monitor ds_cpl cid xtpr

 If you are using a recent CVS checkout,
 please e-mail the above to mythtv-users at mythtv.org
 With the subject "configure did not detect my cpu"



More information about the mythtv-users mailing list