[mythtv-users] Setting up audio input from STB with pcHDTV-5500

Bob Sully rcs at malibyte.net
Sun Jan 28 02:31:41 UTC 2007

OK, this is probably the last significant issue I'll have with Myth basics.

I have the digital and analog inputs working...watch live, record, etc. -
all good.

I'd like to use the s-video input from the STB as an alternate input, as
this would allow me to record on any channel (not just the analog channels
and unencrypted digital ones).  However, I can't get sound to work.

As per the instructions, I have the audio output from the STB plugged into
the audio-in jack on the tuner card.  The adapter that came with the tuner
card has an s-video and composite video in, and a line-out jack - the
latter is plugged into the line-in jack on my sound card (Creative Audigy
2 ZS).

Unfortunately, Myth only allows one sound source for both the analog tuner
and s-video input (/dev/dsp, the sound card, or /dev/dsp2, the sound
device on the tuner card).  To get sound with the analog tuner, I have to
use /dev/dsp2.  It appears that I cannot get sound with the s-video input
if I use dsp2; I have to use /dev/dsp.

I would LOVE to see this fixed in the next release (allow the ability to
use different sound sources for each analog input)....please?

Anyway...if I use /dev/dsp, I can get sound from the STB...but only if I
increase the "analog mix" setting in Kmix.  And if I do this, the sound
from the STB **never** shuts off.

Does anyone out there have this setup working - and if so, could you clue
me in as to the proper configuration?


Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list