[mythtv-users] HDHomerun and previews (crashes backend)

Billy Macdonald billymacdonald at gmail.com
Thu Jan 25 22:47:11 UTC 2007

On 1/25/07, Mark Chang <mark.chang at gmail.com> wrote:
> On 1/25/07, Michael Tiller <michael.tiller at gmail.com> wrote:
> > My problem is with thumbnail generation.  The FFMPEG code is generally not
> > very robust to garbage data structures.  As a result, it will divide by
> > zero, dereference null pointers, etc.  Where does the garbage come from?
> > Well it consistently comes from my HDHomerun.  This is a bit odd since I'm
> > capturing from QAM and my signal strengths all seem quite reasonable.  So it
> > is not a reception problem and I'm assuming its not a lock problem.  But
> > nevertheless when FFMPEG tries to generate previous it crashes the backend
> > (at this point it is always a segfault but sometimes it comes directly from
> > the FFMPEG code and sometimes it comes from free/malloc due, presumably, to
> > a corrupte malloc heap or something).
> I'm using ubuntu edgy binaries w/OTA through my HDHR. Because of me
> messing with my antenna, I have had lots of artifacts on recordings.
> The thumbnail generation has never crashed my system, FWIW.
> Mark

I recently got one of these devices.  I haven't had the crashes but I
do believe I've seen something in the logs to the effect that preview
generation failed.  I'll look when I get home.

I've also noticed that at the beginning of a few recordings there are
often a few glitches and dropouts, but then it's fine for the rest of
the show.

More information about the mythtv-users mailing list