[mythtv-users] Something evil broke my D11 Channel Change Script

Brad DerManouelian myth at dermanouelian.com
Thu Jan 25 00:46:16 UTC 2007

I've got another one of those, "Everything works great, then I  
upgraded..." stories.
Last week it was lirc. Thist ime my D11 channel change script has  
decided not to work any more.

Actually, it seems like my whole system is falling apart. I started  
getting rather silent failed recordings. I look back in the logs and  
all I see if that the recorder failed. I see that one of my recorders  
is trying to change to some wacky channel numbers that don't exist.  
So I dumped all my cards and added them all again (a PVR-350, HD-5500  
in my master backend and a PVR-150 in my slave backend. The SD cards  
are both connected to D11 DirecTV boxes and my HD is OTA.)

Now when I start up the backend I get failures on trying to tune both  
D11 boxes. Here's what the script gives me:

[mythtv at mythtv ~]$ ls -l /dev/ttyS0
crw-rw---- 1 root uucp 4, 64 Jan 24 16:21 /dev/ttyS0

ok, so I'm the mythtv user who is also in the uucp group.

[mythtv at mythtv ~]$ d11channel.pl 2
Initializing Serial Port...
Error opening /dev/ttyS0!

ok, so let's try it as root:

[mythtv at mythtv ~]$ sudo d11channel.pl 2
Initializing Serial Port...
Retry Wed Jan 24 16:26:37 2007
Retry Wed Jan 24 16:26:39 2007
Retry Wed Jan 24 16:26:41 2007
Retry Wed Jan 24 16:26:43 2007
Error excessive retries
         (in cleanup) Can't call method "opened" on an undefined  
value at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/ 
Device/SerialPort.pm line 2020 during global destruction.

This is happening on both my master backend and my slave which I both  
"successfully" updated. That'll teach me to keep up to date.

Any ideas?

More information about the mythtv-users mailing list