[mythtv-users] Mythbackend Segfault on Delete SOLVED!!

Jarod Wilson lists at wilsonet.com
Wed Jan 24 15:06:22 UTC 2007

Axel Thimm wrote:
> On Mon, Jan 22, 2007 at 03:08:43PM -0800, Kirk Bocek wrote:
>> My problem was a libmyth package that was older than the mythbackend package. 
>> I was accidentally entering 'yum update myth\*' to update instead of 'yum 
>> update \*myth\*' when updating from atrpms.
>> Hey, Axel, I thought yum was supposed to at least warn about dependencies like 
>> this?
> Please imagine the next line in loud capital letters:
> don't use selective/partial upgrading. you - are - on - your - own!
> On even larger letters:
> don't even bug packagers and upstream about that! you - created - this
> - bug!
> And in largest fonts, blinking in red
> go after the people advising to do so, find them and kill them

I think you just put out a hit on me. :)

> If the above sounds harsh, it's for educational purposes. If you don't
> know the background just google for partial and/or selective upgrades.

That holds more for having a repo disabled, but pulling in select 
packages, I thought. With the repo enabled and a request to upgrade only 
certain components, things really ought to work just fine. I do this all 
the time w/o problem... For example, I only wanted to upgrade to libdv 
and dvgrab out of fedora updates-testing yesterday, so I did a 'yum 
upgrade libdv\* dvgrab'. Its always worked for me for myth package 
upgrades as well, as long as its \*myth\* and not myth\*. But in 
thinking about it, why not have a full e-v-r dep in mythtv-backend 
and/or mythtv-frontend on libmyth? I don't want to do a full yum upgrade 
every time I want just a few updated packages...


More information about the mythtv-users mailing list