[mythtv-users] lirc/mythfrontend quit working

Greg Woods greg at gregandeva.net
Tue Jan 23 00:29:16 UTC 2007

On Fri, 2007-01-19 at 11:15 -0800, Robert Anderson wrote:

> lircd -n
> Watch the output as you connect with irw (for comparison), and again
> as you launch mythfrontend.

I did this. When I use "irw", there is a message like:

lircd-0.8.1-CVS[2663]: accepted new client on /dev/lircd

There is no output when I run mythfrontend. This is not surprising; it
just looks like mythfrontend isn't using lirc at all. But it does show

# ldd mythfrontend | grep lirc
        liblirc_client.so.0 => /usr/lib/liblirc_client.so.0 (0x0248c000)

It is also the byte-for-byte identical binary with the one on the MBE/FE
that works fine.

I ran mythfrontend under strace, and that also shows:

open("/usr/lib/liblirc_client.so.0", O_RDONLY) = 3

So lirc is compiled in, it is able to load the library, but it isn't
actually using lirc. The open line above is the result of "grep
lirc /tmp/mythfrotend.str" after running "strace
-o /tmp/mythfrontend.str mythfrontend", and it too is identical on both

"ls -l /dev/lirc*" produces identical output on both machines:

lrwxrwxrwx 1 root root     5 Jan 22 17:12 /dev/lirc -> lirc0
crw------- 1 root root 61, 0 Jan 22 17:12 /dev/lirc0
srw-rw-rw- 1 root root     0 Jan 22 17:12 /dev/lircd

Also, I did check, and the symptoms are the same with mythtv-setup (the
remote works on the MBE/FE system, but not on the little FE system).

Anything else I can try? I am really stumped and the WAF is dropping
fast :-)


More information about the mythtv-users mailing list