[mythtv-users] Cannot get EIT and picture data on same channel

Philip Allison slightly at pathetic.co.uk
Mon Jan 22 20:21:55 UTC 2007

I have a Freecom DVB-T USB stick (rev 3), and am trying to receive
Freeview in the UK. A MythTV full scan finds most channels, but many are
unwatchable (no lock) - however EIT data seems to be retrieved for them
fine. dvbscan is capable of finding all channels, but does not number them

Currently, I have imported channels.conf from dvbscan, then run a full
scan of existing transports from mythtv-setup (without deleting imported
channels). For all bar a few channels, I have ended up with at least two
entries; for example BBC ONE is present both as channel 1 (found by mythtv
scan), and channel 541 (found by dvbscan). If I set MythTV to channel 1, I
get EIT data, and the EPG works fine, but there is no signal lock and
hence no picture/sound. Setting it to channel 541 gives me picture, sound,
MHEG etc., but the EPG doesn't work.

I have tried simply renumbering channel 541 to 1, but that didn't
magically associate the EPG data with it. I'm assuming it remained
associated with the "old" channel 1, which was no longer visible or
selectable in the listings.

Importing channels.conf, deleting all channels, then doing a scan of
existing transports gives me one copy of each channel, with working EPG,
but no picture or sound.

My hardware and signal are clearly capable or retrieving both
picture/sound and EIT, so my question is, how can I convince MythTV to
match the two up on working, tunable channels?

More information about the mythtv-users mailing list