[mythtv-users] I'm almost done, I only have a sound issue left.

Robert Longbottom RobertCL at iname.com
Sun Jan 21 08:53:44 UTC 2007

Lists wrote:
> So I have mythTV all setup and running properly on fedora core 6. Here is my 
> problem:
> I can play DVD movies (ripped and non-ripped) and I get sound fine. The 
> problem comes in when I try to watch live TV or record Live TV.
> I can get the sound to play with a
> arecord -D hw:1,0 -r 32000 -c 2 -f S16_LE | aplay -
> But that doesn't allow for the 2 second buffer that mythtv has.  I figure 
> the problem is with the input device  from the configure capture card in the 
> mythtvsetup -> config capture cards -> audio input device.  I tired setting 
> that to /dev/dsp1, but when I do that the video comes out choppy and the 
> audio is very high pitched. I think the reason is because /dev/dsp1 is 
> suppposed to be a oss driver, and the only driver that comes with FC6 is the 
> "ALSA" driver not the oss driver. I have tried the sox method of coverting 
> the stream to the oss /dev/dsp but I still get no audio from the TV.
> I am currently trying to install the DEPRICATED OSS kernel module. Is this 
> the correct way to go?

I would say not.  Alsa should still allow you to use /dev/dsp* (my setup 
certainly does).  There is a kernel option under the Alsa setup called 
"OSS PCM (digital audio) API".  I think this is the one that provides 
the /dev/dsp* devices for Alsa.  The fact that you already have 
/dev/dsp1 however implies that you probably already have this option 
selected, so the problem must be elsewhere.

Have you tried changing the sampling rate in mythtv-setup?  This might 
help.  Other than that, I'm not sure what to suggest - maybe someone 
else will have some good ideas.


More information about the mythtv-users mailing list