[mythtv-users] resolution switching problem on FX5200

Marco Nelissen marcone at xs4all.nl
Sun Jan 21 02:57:26 UTC 2007

This problem has been plagueing me since driver version 8776 (before
that I used 8178 which worked OK), and I'm wondering if anyone else
ran into it and solved it:
I've set mythtv to run its UI in 1920x1080, and to switch resolutions
based on the material being played. Since I only use the machine for
HD, that means it's supposed to be in either 1080i or 720p at any
given time. What happens "out of the box" is that mythtv comes up in
1080i at 120 Hz (Xorg log shows this as mode "1920x1080_120i_0").
Since my display doesn't support this mode, it only shows the top
half. I worked around this particular problem by adding some code
to mythtv to reject any modes with a full frame rate greater than
40 Hz.
The next problem is that after playing 720p content, the UI doesn't
switch back to 1080i. I worked around this by binding the appropriate
'xrandr' command to switch to 1080i to a key on the remote.
The final problem is that when playing a 1080i recording right after
startup, it's shown vertically compressed. The only way I've found
to get around that is to first play some 720p recording (I have to
keep a recording around specifically for this), and then play the
1080i recording. After that, 1080i recordings always play OK.

Anyone else seen any of the above problems and/or know of a solution?

More information about the mythtv-users mailing list