[mythtv-users] IPTV: no sound, except from mplayer. Need Codec Help

Nate Crosno nate at crosno.net
Fri Jan 19 22:22:07 UTC 2007

Hi Group,

I'm still playing around with our net IPTV setup.  I can save the stream 
to a file with VLC, but am getting very mixed results during playback.
- Mythtv gives no video or audio
- Xine and VLC have video but no audio
- mplayer has both video and audio, but the audio sync is way off.

I tried some searches through the archive on ac3, a52, and liba52, but 
didn't find anything I could use.

I have tried the various options in VLC and Xine to choose different 
audio tracks, but none worked. Just as a quick test, I fed the test file 
through mencoder and converted it to DVD format and was able to play the 
file in Myth. (by executing "mythtv <filename>").  My motherboard just 
has basic stereo output and I've tried several different settings for 
audio. Right now I have ALSA selected for the audio driver.  Enabling 
the AC3/SDIF passthrough would only be if my hardware had digital 
output, right?

Here are some logs from each Myth and Mplayer when playing the saved stream:

Mythtv (no audio or video)
stream: start_time: 45037.419 duration: 27.520 bitrate=3623 kb/s
2007-01-19 08:43:19.203 AFD: Stream #0, has id 0x101 codec id AC3, type 
Audio, bitrate 192000 at 0x0x81f02c0
2007-01-19 08:43:19.203 AFD: Looking for decoder for AC3
2007-01-19 08:43:19.204 AFD: Opened codec 0x81f2870, id(AC3) type(Audio)
2007-01-19 08:43:19.204 RingBuf(test2.mpg): CalcReadAheadThresh(192 KB)
                          -> threshhold(32 KB) min read(32 KB) blk 
size(32 KB)
2007-01-19 08:43:19.207 Opening ALSA audio device 'default'.
2007-01-19 08:43:19.226 Dec: Trying to select track (w/lang)
2007-01-19 08:43:19.226 Dec: Selecting first track
2007-01-19 08:43:19.226 Dec: Selected track #1 in the Unknown language(0)
2007-01-19 08:43:19.226 Resyncing position map. posmapStarted = 0 
livetv(0) watchingRec(0)
2007-01-19 08:43:19.228 SyncPositionMap prerecorded, from DB: 0 entries
2007-01-19 08:43:19.228 AFD: Recording has no position -- using 
libavformat seeking.
2007-01-19 08:43:19.229 AFD: Successfully opened decoder for file: 
"test2.mpg". novideo(0)
2007-01-19 08:43:19.236 VideoOutputXv: ctor
2007-01-19 08:43:19.237 Over/underscan. V: 0, H: 0, XOff: 0, YOff: 0
2007-01-19 08:43:19.237 Display Rect  left: 0, top: 0, width: 1280, 
height: 720, aspect: 1.33333
2007-01-19 08:43:19.237 Video Rect    left: 0, top: 0, width: 0, height: 
0, aspect: 1.33333
2007-01-19 08:43:19.237 VideoOutputXv: Pixel dimensions: Screen 
1280x720, window 1280x720

Mplayer (audio out of sync, but all else OK)
Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 0, TLEN: 13, COLLECTED: 184
PARSE_PAT: section_len: 13, section 0/0
PROG: 35 (1-th of 1), PMT: 2
AC3: 2.0 (stereo)  48000 Hz  192.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0x2
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)

More information about the mythtv-users mailing list