[mythtv-users] IPTV Recording: No Sound. Audio codec problem?

Nate Crosno nate at crosno.net
Fri Jan 19 02:17:45 UTC 2007

Hi All,

Never got any hits on this, but I have found out a little more.  Mplayer 
is able to play the sound from these files, but it's way out of sync 
with the video...better than nothing though.  Here is part of the output 
from mplayer:

Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 0, TLEN: 13, COLLECTED: 184
PARSE_PAT: section_len: 13, section 0/0
PROG: 35 (1-th of 1), PMT: 2
AC3: 2.0 (stereo)  48000 Hz  192.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0x2
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)

Any ideas on how to get it playing in Myth is greatly appreciated!  
Trying not to go through the video screen.


-----Original Message-----
From: Nate Crosno
Sent: Tuesday, January 09, 2007 11:38 AM
To: 'Discussion about mythtv'
Subject: IPTV Recording: No Sound. Audio codec problem?

Hi All, I'm reposting a previous question to the list but breaking out 
the more pressing question at the moment, adding more info, and changing 
the subject line...

I have been able to view and save the IPTV streams on the Myth box that 
are going to my little Amino STB by splitting the cable with hub.  I can 
save the stream with a command like this:

vlc udp:@ --ts-dump-file test.mpg

Or I can view the stream with either of these commands:

vlc udp:@
xine udp://

...however I do not get any sound.  I copied the test file to a windows 
box and did get sound when watching VLC.  I have tried to compare the 
file with known good files saved off my HD DVB card and cannot tell the 
difference -- both have A/52 set as the audio codec and MPEGTS for video.

Using "midentify", I get the following when comparing the saved IPTV 
file to a known good HD file:

Ati HD Wonder File        IPTV File
ID_DEMUXER=mpegts            ID_DEMUXER=mpegts
ID_VIDEO_FORMAT=0x10000002    ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_FPS=59.940        ID_VIDEO_FPS=29.970
ID_VIDEO_ASPECT=0.0000        ID_VIDEO_ASPECT=0.0000
ID_AUDIO_RATE=48000        ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2            ID_AUDIO_NCH=2
ID_LENGTH=7.26            ID_LENGTH=2.30
ID_VIDEO_CODEC=mpegpes        ID_VIDEO_CODEC=mpegpes

Any ideas on how to get the audio working would be greatly appreciated.  
Also, I tried to play the IPTV file in myth via "mythtv test.mpg", but 
that bombed out. I can provide logs if anyone is interested.

Once I get the sound playing at all, I'll worry about step 2, which is 
getting Myth to record and play the files.


More information about the mythtv-users mailing list