[mythtv-users] Problems with ffmpeg - error "ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: dlclose"

Axel Thimm Axel.Thimm at ATrpms.net
Tue Jan 16 20:43:07 UTC 2007

On Tue, Jan 16, 2007 at 06:53:22AM -0800, Pierre Rochefort wrote:
> Hi,
> I just upgraded my Myth box from Fedora Core 4 to Fedora Core 6. (Clean install )
> The good news: After the upgrade, I was able to get my two Hauppauge PVR-150s to work (FC4 wouldn't have it)
> The bad news: ffmpeg no longer starts correctly. It simply stops
> with the following error message "ffmpeg: symbol lookup error:
> /usr/lib/libavcodec.so.51: undefined symbol: dlclose".

This seems to happen if you use x264 from Dries or another repo.

> I tried to remove ffmpeg and libavcodec51 (from atrpms) but no luck.
> Tried to add /usr/lib to ld.so.conf and run ldconfig. No luck
> I searched the web for a solution but nothing seems to fix it. The
> thought has occured to me to recompile from source but without
> knowing which option it was compiled with, I'm a little hesitant to
> do so.
> Has anyone ever encountered this problem and how did you fix it?

Reinstall x264 from ATrpms.

> As always, if you don't want to flood the list, you can respond
> directly to me.

Then the lists gets flooded by the same question over and over again
w/ no answer in the archives ;)

BTW googling for "/usr/lib/libavcodec.so.51: undefined symbol:
dlclose" would had gotten you to several threads on that.
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20070116/b10aab27/attachment.pgp 

More information about the mythtv-users mailing list