[mythtv-users] Problems with ffmpeg - error "ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: dlclose"

Pierre Rochefort rochefort_pierre at yahoo.ca
Tue Jan 16 14:53:22 UTC 2007


I just upgraded my Myth box from Fedora Core 4 to Fedora Core 6. (Clean install )
The good news: After the upgrade, I was able to get my two Hauppauge PVR-150s to work (FC4 wouldn't have it)
The bad news: ffmpeg no longer starts correctly. It simply stops with the following error message "ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: dlclose".

I tried to remove ffmpeg and libavcodec51 (from atrpms) but no luck.
Tried to add /usr/lib to ld.so.conf and run ldconfig. No luck
I searched the web for a solution but nothing seems to fix it. The thought has occured to me to recompile from source but without knowing which option it was compiled with, I'm a little hesitant to do so.

Has anyone ever encountered this problem and how did you fix it?
As always, if you don't want to flood the list, you can respond directly to me.

Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070116/f6ced44a/attachment.htm 

More information about the mythtv-users mailing list