[mythtv-users] Compilation problem on amd64 debian etch

Chris Bayly cbayly at gmail.com
Sun Jan 14 23:55:41 UTC 2007

On 11/11/06, Rudy Zijlstra <mythtv at edsons.demon.nl> wrote:
> Michael T. Dean wrote:
> >On 11/11/2006 02:51 PM, Rudy Zijlstra wrote:
> >>Rudy Zijlstra wrote:
> >>>I've recently installed debian etch (testing) with some packages from
> >>>unstable. I've got several mythtv compiled from SVN running on slackware,
> >>>debian though is new to me.
> >>>
> >>>I'm getting the following compile error, and i suspect i've got a missing
> >>>package. Can someone help me find the correct package?
> >>>
> >>>In file included from ttfont.h:4,
> >>>                from osdlistbtntype.h:38,
> >>>                from tv_play.cpp:19:
> >>>/usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: No such file
> >>>
> >>>
> >>After manually editing Makefile to add -I/usr/include/freetype2 to the
> >>compiler include list things compiled.
> >>
> >>There is probably a patch lurking here, but i have not the skill to make it.
> >
> >Does your system, by any chance, have freetype1 and freetype2 installed
> >such that the freetype2 script "freetype-config" was changed to
> >"freetype2-config" and "freetype-config" returns information for
> >freetype1 or something crazy like that?  If not, it sounds like your
> >freetype-config script is broken (i.e. "freetype-config --cflags"
> >returns incorrect information).
> >
> >Mike
> >
> >
> Its got only freetype2 installed. Script output:
> barak:~# freetype-config --cflags
> -I/usr/include/freetype2
> Rudy

For the archives of this mailing list... I've seen this on a
mythtv-0.20 install on Ubuntu Edgy as well.  I added the -I flag to
the makefile and everything else built clean.

Chris Bayly
cbayly at gmail.com

More information about the mythtv-users mailing list