[mythtv-users] Getting an error loading firmware for PVR-350

stephen mythmail at rogers.com
Fri Jan 12 00:31:58 UTC 2007

Scott Simpson wrote:
> Fedora Core 6 using Jarod Wilson's Guide, new install
> When ivtv driver loads, I get the error
> ivtv0: unable to open firmware v4l-cx2341x-init.mpg (must be 155648 bytes)
> yet the firmware is in all the appropriate directories:
> # ls -l $(locate v4l-cx2341x-init.mpg)
> lrwxrwxrwx 1 root root     33 Jan 10 
> 20:47 /lib/firmware/v4l-cx2341x-init.mpg -> /lib/modules/v4l-cx2341x-init.mpg
> -rwxr-xr-x 1 root root 155648 Dec 29  2005 /lib/modules/v4l-cx2341x-init.mpg
> lrwxrwxrwx 1 root root     33 Jan 10 
> 20:47 /usr/lib/hotplug/firmware/v4l-cx2341x-init.mpg -> /lib/modules/v4l-cx2341x-init.mpg
> Notice the size matches. The checksum is
> # md5sum -b /lib/modules/v4l-cx2341x-init.mpg
> 0661f8b2693fe3123e6234557353eacc */lib/modules/v4l-cx2341x-init.mpg
> I know the card is good because I was running under Fedora Core 4 last week 
> and everything worked fine. I'm trying upgrade since FC4 isn't supported 
> anymore.
> I saw messages from a bunch of other people with the same problem during the 
> last year but nobody seems to have a solution.

I don't know how helpful this will be, but I had a similar issue a few 
days ago.  The differences between my problem and the one you listed are:

  - the file that wouldn't load for me was v4l-cx2341x-enc.fw, not 
  - I run gentoo, not fedora

I'm not sure what your kernel and ivtv versions are, but I'm using 
2.6.18-gentoo-r1 and ivtv-0.8.2-r1.

The help I found was on a forum for ubuntu:


The post by "Stormbringer" (about 2/3 down the page) was what pointed me 
in the right direction -- turns out all I had to do was create a symlink 
like this:

cd /usr/lib/hotplug/firmware/
ln -s /lib/firmware/v4l-cx2341x-enc.fw v4l-cx2341x-enc.fw

So, if this doesn't help, maybe it will at least give you a few areas to 
explore ...


More information about the mythtv-users mailing list