[mythtv-users] lirc issues after vacation

devsk funtoos at yahoo.com
Fri Jan 5 17:17:07 UTC 2007

I don't use Ubuntu, so I can't really help with packaging part. Moreover, I can only speak from the personal experience, which is with the card pvr-usb2. The deal is that the IR functionality is provided by conjunction of two drivers: for me lirc_i2c (which autoloads lirc_dev, could be different for you) and device specific driver (for me it was 'pvrusb2'). The IR goes to the device recvr, is emmited out as events to /dev/lirc/0 provided by the pvrusb2 driver, lircd receives it from /dev/lirc/0 and routes it to specific programs. Now, you need to have IR functionality working in both lirc_i2c and pvrusb2. You need to dig deeper (google, ubuntu forums) and see which one got updated. If you can post the names of exact modules for your devices, we can maybe help.

since, /dev/lirc/0 is not there in your case as well (for me pvrusb2 was the culprit, it didn't really create /dev/lirc/0 because that functionality wasn't present in the in-kernel module), its the tuner specific driver that you are looking at, not the lirc specific driver.


----- Original Message ----
From: Davey McWatters <daveyiv at adelphia.net>
To: Discussion about mythtv <mythtv-users at mythtv.org>
Sent: Friday, January 5, 2007 8:40:34 AM
Subject: Re: [mythtv-users] lirc issues after vacation

Brad DerManouelian wrote:
> On Jan 5, 2007, at 8:25 AM, Fred Clausen wrote:
>> I really believe that the problem lies with the fact that you don't  
>> have
>> the appropriate kernel module loaded, try:
>> # modinfo lirc_i2c
>> and see if any info is printed. You can also try:
>> # modprobe lirc_i2c
>> and see if that works. Chances are that you had the correct module
>> before you updated your system but now the kernel module package  
>> has not
>> been update but your kernel has. But I don't how the lirc kernel  
>> modules
>> are packaged in Ubuntu. From some light googling, it seems you have to
>> compile the drivers from source.
>> Cheers,
>> Fred.
> I honestly don't know the first thing about Ubuntu, but ironically  
> enough I had this same problem last night. My machine hard-locked and  
> I needed a reboot - forgetting that I had updated the kernel and not  
> rebooted. So when it came back I needed to install the kernel modules  
> for my new nvidia driver, lirc, alsa, etc. nvidia was it's usual try  
> the latest, doesn't work, try 1 version back, doesn't work, try 5  
> versions back, yay it works. But lirc never worked correctly until I  
> finally uninstalled it and reinstalled (yes, the same version).  
> Magically is started working. So maybe you can use apt to remove lirc  
> and reinstall and see how it goes.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

I tried completely removing it last night, but I guess I missed 
something, because when I reinstalled it, it is still doing the exact 
same thing.
mythtv-users mailing list
mythtv-users at mythtv.org

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070105/1f59aeec/attachment.htm 

More information about the mythtv-users mailing list